aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2018-03-27 20:32:16 +0200
committerTomáš Čech <sleep_walker@gnu.org>2018-04-04 15:51:20 +0200
commit0d0cf3b0f6fd0b24e13704aece9c53ca2e4dcca3 (patch)
tree1f0c330c96bbc22d433acb311fcdc8d9d6893080 /gnu/packages/python.scm
parent55dc0038771613b55d6e673ac628936f3ba4232c (diff)
downloadguix-0d0cf3b0f6fd0b24e13704aece9c53ca2e4dcca3.tar
guix-0d0cf3b0f6fd0b24e13704aece9c53ca2e4dcca3.tar.gz
python: python-py3status: Update to 3.7.
* gnu/packages/python.scm (python-py3status): Update to 3.7. [arguments]: Adjust string substitution.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e6ae8f433b..3bb6e2b0b7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8616,14 +8616,14 @@ to occurrences in strings and comments.")
(define-public python-py3status
(package
(name "python-py3status")
- (version "3.1")
+ (version "3.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "py3status" version))
(sha256
(base32
- "0i283z1pivmir61z8kbiycigc94l61v33ygzkhczf1ifq7cppyds"))))
+ "0shxcfz4wcczj0mhwp4w0dvwd2fdd9bgprq8slim1519iiqzgwhq"))))
(build-system python-build-system)
(inputs
`(("file" ,file)))
@@ -8636,8 +8636,8 @@ to occurrences in strings and comments.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((file-path (assoc-ref inputs "file")))
(substitute* "py3status/parse_config.py"
- (("check_output\\(\\['file'")
- (string-append "check_output(['" file-path "/bin/file'")))
+ (("\\['file', '-b'")
+ (string-append "['" file-path "/bin/file', '-b'")))
#t))))
#:tests? #f)) ; TODO: Requires many libraries not in Guix.
(home-page "https://github.com/ultrabug/py3status")