aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-02 20:03:09 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-05 13:16:33 +0200
commit02dc4b8095750889f2e9c854d94fa2485bed2537 (patch)
tree3ac7f211c8fe754334453f6c340ec2b5e3b9317e /gnu/packages/python.scm
parent560acf259499b0730358eaaa077c2530c803fc60 (diff)
downloadguix-02dc4b8095750889f2e9c854d94fa2485bed2537.tar
guix-02dc4b8095750889f2e9c854d94fa2485bed2537.tar.gz
gnu: Add python-sphinx-gallery.
* gnu/packages/python.scm (python-sphinx-gallery, python2-sphinx-gallery): New public variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f63460b8ff..7a4eee32ca 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2501,6 +2501,36 @@ sources.")
(propagated-inputs `(("python2-pytz" ,python2-pytz)
,@(package-propagated-inputs base))))))
+(define-public python-sphinx-gallery
+ (package
+ (name "python-sphinx-gallery")
+ (version "0.1.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sphinx-gallery/sphinx-gallery"
+ "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03fs99mcb1r7qp0xixqv07vcz98sk21yq19ffdysi0infdcpzfkd"))))
+ (build-system python-build-system)
+ (arguments
+ ;; FIXME: Tests attempt to download <https://docs.python.org/3/objects.inv>,
+ ;; <https://docs.scipy.org/doc/numpy/objects.inv>, and
+ ;; <https://matplotlib.org/objects.inv>.
+ `(#:tests? #f))
+ (native-inputs
+ `(("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://sphinx-gallery.github.io/")
+ (synopsis "Generate an examples gallery automatically")
+ (description
+ "@code{sphinx_gallery} is a Sphinx extension that builds an HTML version
+from any set of Python scripts and puts it into an examples gallery.")
+ (license license:bsd-3)))
+
+(define-public python2-sphinx-gallery
+ (package-with-python2 python-sphinx-gallery))
+
(define-public python-sphinx-rtd-theme
(package
(name "python-sphinx-rtd-theme")