aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-09 14:40:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-09 14:44:49 +0100
commitce2cfcabfccbd6062ab4029258ab61b308508c62 (patch)
treeff6c31e813d29c5f142e97b9000d90b93e0c8fc7 /gnu/packages/python.scm
parentba62f087bc5d47897f2cfd5b7335f4f70b53da5b (diff)
downloadguix-ce2cfcabfccbd6062ab4029258ab61b308508c62.tar
guix-ce2cfcabfccbd6062ab4029258ab61b308508c62.tar.gz
gnu: python-pandas: Update to 0.22.0.
* gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/patches/python-pandas-skip-failing-tests.patch: Delete file. * gnu/packages/python.scm (python-pandas): Update to 0.22.0. [source](patches): Remove. [native-inputs]: Add PYTHON-PYTEST and PYTHON-LXML. [arguments]: Replace CHECK-PHASE with custom pytest invocation. [home-page]: Use HTTPS.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm38
1 files changed, 31 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ac8927c0f1..6e08e38b45 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1066,24 +1066,48 @@ human-friendly syntax.")
(define-public python-pandas
(package
(name "python-pandas")
- (version "0.19.2")
+ (version "0.22.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pandas" version))
(sha256
- (base32 "0540cnbwy2hc4hv2sxfs8i47xi91qzvzxfn80dl785ibiicly3vg"))
- (patches
- (search-patches "python-pandas-skip-failing-tests.patch"))))
+ (base32 "0v0fi2i10kwnmlpsl6f1fgajcpx3q6766qf6xqi5kw3ivn8l1aa4"))))
(build-system python-build-system)
+ (arguments
+ `(#:modules ((guix build utils)
+ (guix build python-build-system)
+ (ice-9 ftw)
+ (srfi srfi-26))
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (let ((build-directory
+ (string-append
+ (getcwd) "/build/"
+ (car (scandir "build"
+ (cut string-prefix? "lib." <>))))))
+ (with-directory-excursion build-directory
+ ;; Delete tests that require "moto" which is not yet in Guix.
+ (for-each delete-file
+ '("pandas/tests/io/conftest.py"
+ "pandas/tests/io/json/test_compression.py"
+ "pandas/tests/io/test_excel.py"))
+ (invoke "pytest" "-v" "pandas" "-k"
+ (string-append
+ "not network and not disabled"
+ ;; XXX: Due to the deleted tests above.
+ " and not test_read_s3_jsonl")))))))))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-pytz" ,python-pytz)
("python-dateutil" ,python-dateutil)))
(native-inputs
- `(("python-nose" ,python-nose)
- ("python-cython" ,python-cython)))
- (home-page "http://pandas.pydata.org")
+ `(("python-cython" ,python-cython)
+ ("python-lxml" ,python-lxml)
+ ("python-nose" ,python-nose)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://pandas.pydata.org")
(synopsis "Data structures for data analysis, time series, and statistics")
(description
"Pandas is a Python package providing fast, flexible, and expressive data