aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-04-27 06:58:04 +0000
committerLudovic Courtès <ludo@gnu.org>2018-04-30 14:35:05 +0200
commit8b2597d54286ccf140592ea352fd19c7323f7746 (patch)
tree40bf722d02a657ff0ef442979b989febc417839e /gnu/packages/python.scm
parent5986e94118b114319feadbd2431d6efbf870a5e5 (diff)
downloadguix-8b2597d54286ccf140592ea352fd19c7323f7746.tar
guix-8b2597d54286ccf140592ea352fd19c7323f7746.tar.gz
gnu: Add python-parso.
* gnu/packages/python.scm (python-parso, python2-parso): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 04ab52eb9f..f23deb57e6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13145,3 +13145,27 @@ in Python. You can simply type pybtex instead of bibtex.")
(description "Python one-time password library for HMAC-based (HOTP) and
time-based (TOTP) passwords.")
(license license:expat)))
+
+(define-public python-parso
+ (package
+ (name "python-parso")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "parso" version))
+ (sha256
+ (base32
+ "0lamywk6dm5xshlkdvxxf5j6fa2k2zpi7xagf0bwidaay3vnpgb2"))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (build-system python-build-system)
+ (home-page "https://github.com/davidhalter/parso")
+ (synopsis "Python Parser")
+ (description "Parso is a Python parser that supports error recovery and
+round-trip parsing for different Python versions (in multiple Python versions).
+Parso is also able to list multiple syntax errors in your Python file.")
+ (license license:expat)))
+
+(define-public python2-parso
+ (package-with-python2 python-parso))