aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 23:11:57 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commit5477e05f016c1d1696191e93855dfeb525f53ebd (patch)
treee1ef1a8ee8035cd042c1db0b23115bf3315491c6 /gnu/packages/python.scm
parent77cadb436be83557d17605565af1b17e574bdb68 (diff)
downloadguix-5477e05f016c1d1696191e93855dfeb525f53ebd.tar
guix-5477e05f016c1d1696191e93855dfeb525f53ebd.tar.gz
gnu: Add python-dnspython and python2-dnspython.
* gnu/packages/python.scm (python-dnspython, python2-dnspython): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dc9879a8f0..ff3cb99652 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9442,3 +9442,29 @@ until the object is actually required, and caches the result of said call.")
(define-public python2-lazy-object-proxy
(package-with-python2 python-lazy-object-proxy))
+(define-public python-dnspython
+ (package
+ (name "python-dnspython")
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.dnspython.org/kits/"
+ version "/dnspython-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z472r63gdqsxhsxj3plr5vs478yf4303vrqxxpsccc940g441hl"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; XXX: requires internet access
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://www.dnspython.org")
+ (synopsis "DNS toolkit for Python")
+ (description
+ "dnspython is a DNS toolkit for Python. It supports almost all record
+types. It can be used for queries, zone transfers, and dynamic updates.
+It supports TSIG authenticated messages and EDNS0.")
+ (license license:expat)))
+
+(define-public python2-dnspython
+ (package-with-python2 python-dnspython))
+