aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-04 21:48:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:49 +0200
commit603a64920f13a28a5b62cb8aedf1f460f08e15f0 (patch)
tree42ddf966b9bc1af85c91faa09fce666d003c9b8e /gnu/packages/python.scm
parent9d8796a5169238f00705bbda8885667a24219388 (diff)
downloadguix-603a64920f13a28a5b62cb8aedf1f460f08e15f0.tar
guix-603a64920f13a28a5b62cb8aedf1f460f08e15f0.tar.gz
gnu: python@2: Update to 2.7.14.
* gnu/packages/python.scm (python-2.7): Update to 2.7.14. [source]: Add patch to skip two new tests. Delete upstreamed patch. * gnu/packages/patches/python-2.7-adjust-tests.patch: New file. * gnu/packages/patches/python-2.7-getentropy-on-old-kernels.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 46df5eaca8..7aba0833f0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -132,7 +132,7 @@
(define-public python-2.7
(package
(name "python")
- (version "2.7.13")
+ (version "2.7.14")
(source
(origin
(method url-fetch)
@@ -140,12 +140,12 @@
version "/Python-" version ".tar.xz"))
(sha256
(base32
- "0cgpk3zk0fgpji59pb4zy9nzljr70qzgv1vpz5hq5xw2d2c47m9m"))
+ "0rka541ys16jwzcnnvjp2v12m4cwgd2jp6wj4kj511p715pb5zvi"))
(patches (search-patches "python-2.7-search-paths.patch"
"python-2-deterministic-build-info.patch"
"python-2.7-site-prefixes.patch"
"python-2.7-source-date-epoch.patch"
- "python-2.7-getentropy-on-old-kernels.patch"))
+ "python-2.7-adjust-tests.patch"))
(modules '((guix build utils)))
;; suboptimal to delete failing tests here, but if we delete them in the
;; arguments then we need to make sure to strip out that phase when it