aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-21 22:46:06 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-25 22:25:19 -0700
commit92eb9a35355df03803f4dd087d0c2a9e57bd718e (patch)
treebc71c055308001f1775312f2e6aa528577455645 /gnu/packages/python.scm
parentbf7dfb1f0722f48b137f85ade6b075ad342ecb38 (diff)
downloadguix-92eb9a35355df03803f4dd087d0c2a9e57bd718e.tar
guix-92eb9a35355df03803f4dd087d0c2a9e57bd718e.tar.gz
gnu: Add python-humanfriendly.
* gnu/packages/python.scm (python-humanfriendly, python2-humanfriendly): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4b080a8341..cddbd8c208 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1099,6 +1099,36 @@ etc.). The package is structured to make adding new modules easy.")
"python"
(package-inputs pycrypto)))))))
+(define-public python-humanfriendly
+ (package
+ (name "python-humanfriendly")
+ (version "4.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "humanfriendly" version))
+ (sha256
+ (base32
+ "0pisgizjql86785jchfjv217g0lsgk114g2lja5j4y3lsc3b9szi"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; XXX: Tests depend on coloredlogs, which in turn depends on humanfriendly.
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-monotonic" ,python-monotonic)))
+ (home-page "https://humanfriendly.readthedocs.io")
+ (synopsis "Human-friendly input and output in Python")
+ (description
+ "The functions and classes in @code{humanfriendly} can be used to make
+text interfaces more user-friendly. It includes tools to parse and format
+numbers, file sizes, and timespans, timers for long-running operations, menus
+to allow the user to choose from a list of options, and terminal interaction
+helpers.")
+ (license license:expat)))
+
+(define-public python2-humanfriendly
+ (package-with-python2 python-humanfriendly))
+
(define-public python-eventlet
(package
(name "python-eventlet")