aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-10-14 05:52:51 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-22 17:13:15 +0200
commit69f7f0454463124d53b2404f4e701e3d544b94ba (patch)
tree365fb3f580545c97e96adc04f7bf00194172260c /gnu/packages/python.scm
parent7f7fadb592310b4b7103ef0929dfb5b63ddafe08 (diff)
downloadguix-69f7f0454463124d53b2404f4e701e3d544b94ba.tar
guix-69f7f0454463124d53b2404f4e701e3d544b94ba.tar.gz
gnu: python2-hypothesis: fix propagated inputs.
* gnu/packages/python.scm (python2-hypothesis)[propagated-inputs]: Add python2-enum34, which was incorrectly listed among the native inputs.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0684090c3d..2b9e486877 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10150,9 +10150,9 @@ seamlessly into your existing Python unit testing work flow.")
(let ((hypothesis (package-with-python2
(strip-python2-variant python-hypothesis))))
(package (inherit hypothesis)
- (native-inputs
+ (propagated-inputs
`(("python2-enum34" ,python2-enum34)
- ,@(package-native-inputs hypothesis))))))
+ ,@(package-propagated-inputs hypothesis))))))
(define-public python-pytest-subtesthack
(package