aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-17 20:53:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-17 20:53:24 +0200
commit16f14f63db7a370d3917cf9c7d7e3735b0f59855 (patch)
tree367b77f69504cdb55109dcb68aa5a7bc3fe9693b /gnu/packages/python.scm
parentd02bb02f7d833ad371c53c346b6cb77f01377cf4 (diff)
downloadguix-16f14f63db7a370d3917cf9c7d7e3735b0f59855.tar
guix-16f14f63db7a370d3917cf9c7d7e3735b0f59855.tar.gz
gnu: Python: Adjust grafts for core-updates merge.
This adjust the grafts from a55ebe2e3a7b438b4eec06c594440d3a0fb06a25 and 90aeaee861845142843a0f988fa4ff016c723cdb to apply to Python 2.7.15 and 3.7.0. * gnu/packages/patches/python2-CVE-2018-1060.patch, gnu/packages/patches/python2-CVE-2018-1061.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/python.scm (python-2/fixed): Remove patches that are already present in 2.7.15. (python-3/fixed): Remove obsolete phase.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 39ec96fd66..63cf440014 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -323,9 +323,7 @@ data types.")
(inherit (package-source python-2))
(patches (append
(origin-patches (package-source python-2))
- (search-patches "python2-CVE-2018-1060.patch"
- "python2-CVE-2018-1061.patch"
- "python2-CVE-2018-14647.patch"
+ (search-patches "python2-CVE-2018-14647.patch"
"python2-CVE-2018-1000802.patch")))))))
(define-public python2-called-python
@@ -419,17 +417,7 @@ data types.")
(source (origin
(inherit (package-source python-3))
(patches (append (origin-patches (package-source python-3))
- (search-patches "python-CVE-2018-14647.patch")))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-3)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'delete-broken-test
- (lambda _
- ;; Delete test which fails on recent kernels:
- ;; <https://bugs.python.org/issue34587>.
- (delete-file "Lib/test/test_socket.py")
- #t))))))))
+ (search-patches "python-CVE-2018-14647.patch")))))))
;; Current major version.
(define-public python python-3)