aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-22 23:50:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-22 23:50:50 +0300
commitdb9ef31b8f38c14fe325a76caf66bb640740b273 (patch)
tree07db6fea84daa20a2391f3f39899068991a265c9 /gnu/packages/python-xyz.scm
parentb211cd6bacce04c61a8432bc123410144cb654cd (diff)
downloadguix-db9ef31b8f38c14fe325a76caf66bb640740b273.tar
guix-db9ef31b8f38c14fe325a76caf66bb640740b273.tar.gz
gnu: python-structlog: Update to 23.1.0.
* gnu/packages/python-xyz.scm (python-structlog): Update to 23.1.0. [build-system]: Switch to pyproject-build-system. [arguments]: Remove custom 'check phase. [native-inputs]: Add python-hatch-fancy-pypi-readme, python-hatch-vcs, and python-hatchling.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c5da7b1dd5..0d485e060e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15015,26 +15015,22 @@ explicit subcommand name.")
(define-public python-structlog
(package
(name "python-structlog")
- (version "20.2.0")
+ (version "23.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "structlog" version))
(sha256
(base32
- "0x1i21vn3xjfa3j9ijbblia5z0jlzc9aqvpqc26sy16i8yjxyydg"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest"))
- #t)))))
+ "0swh5wxghpzdkncsl3zhiq5bblkj4i5r3g00lldw2qyiswfnh397"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-coverage
+ (list ;; For the build
+ python-hatch-fancy-pypi-readme
+ python-hatch-vcs
+ python-hatchling
+ ;; For the tests
+ python-coverage
python-freezegun
python-pretend
python-pytest