aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-05 23:29:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-05 23:30:43 +0100
commitc85f44431a08c161ca00e35d97d1ab23012749c5 (patch)
tree267e093dfd4038c8bffd27010f369f2ba686e669 /gnu/packages/python-xyz.scm
parent8cc13fcff534e4a8f37d675fed215a265bdaeb4e (diff)
downloadguix-c85f44431a08c161ca00e35d97d1ab23012749c5.tar
guix-c85f44431a08c161ca00e35d97d1ab23012749c5.tar.gz
gnu: python2-numpydoc: Add missing input.
* gnu/packages/python-xyz.scm (python2-numpydoc)[propagated-inputs]: Add python2-jinja2. (python-numpydoc)[properties]: Record python2-variant.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 572d48b0de..209bf5a6bc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4995,10 +4995,17 @@ that client code uses to construct the grammar directly in Python code.")
"Numpy's Sphinx extensions")
(description
"Sphinx extension to support docstrings in Numpy format.")
- (license license:bsd-2)))
+ (license license:bsd-2)
+ (properties `((python2-variant . ,(delay python2-numpydoc))))))
(define-public python2-numpydoc
- (package-with-python2 python-numpydoc))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-numpydoc))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python2-jinja2" ,python2-jinja2)
+ ,@(package-propagated-inputs base))))))
(define-public python-numexpr
(package