aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-06-01 16:57:59 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:43 +0000
commitcb6fec876ae77f3dcc9fec5bfe4bbf5cb95cfd35 (patch)
tree5ddc14a56e53c0d7e293db45ddf68fb75fc5bb16 /gnu/packages/python-xyz.scm
parentc7505f46587051aa931ffbd69bf1183fca066687 (diff)
downloadguix-cb6fec876ae77f3dcc9fec5bfe4bbf5cb95cfd35.tar
guix-cb6fec876ae77f3dcc9fec5bfe4bbf5cb95cfd35.tar.gz
gnu: python-nodeenv: Update to 1.8.0.
* gnu/packages/python-xyz.scm (python-nodeenv): Update to 1.8.0. [build-system]: Use pyproject-build-system. [arguments]: Do not override the check phase, skip tests in #:test-flags instead. Change-Id: I01ca1948c30327827d6f76697b471a4d90cd6530 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7aa0f89e20..e64ae66d1a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28669,7 +28669,7 @@ effort to simplify the man pages with practical examples.")
(define-public python-nodeenv
(package
(name "python-nodeenv")
- (version "1.4.0")
+ (version "1.8.0")
(source
(origin
;; There's no tarball in PyPI.
@@ -28679,15 +28679,13 @@ effort to simplify the man pages with practical examples.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0y443icx0w7jlzmxmmcm4q8dqfiwgafbb9cp8jpm68mbqxbz40a7"))))
- (build-system python-build-system)
+ (base32 "0g8zp8zw5nnfc14ml0sil9yh7lnpz3xrdkazdkwg6pf5jqsxlvv9"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; This test fails. It tries to open a network socket.
- (invoke "pytest" "-vv" "-k" "not test_smoke"))))))
+ (list #:test-flags
+ #~(list "-k" (string-append
+ "not test_smoke"
+ " and not test_smoke_n_system_special_chars"))))
(native-inputs
(list python-coverage
python-mock