aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-09 23:01:57 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 23:01:57 +0200
commit8fbd8c82455e6f1bbbe623965b2452f8f8a01242 (patch)
tree1f908bb10267283a5c16bc44379519ac559d14a1 /gnu/packages/python-xyz.scm
parentfa894b3f4db835bd0bb52b32c7ec412e72b7e03a (diff)
parentb15c0e75f9195ff3f7d0b4da1230939374ef2e34 (diff)
downloadguix-8fbd8c82455e6f1bbbe623965b2452f8f8a01242.tar
guix-8fbd8c82455e6f1bbbe623965b2452f8f8a01242.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 59b4264285..dcade0a579 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1204,13 +1204,13 @@ access the technical and tag data for video and audio files.")
(define-public python-psutil
(package
(name "python-psutil")
- (version "5.9.0")
+ (version "5.9.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "psutil" version))
(sha256
- (base32 "09fa4vfhansixvxd3lv664xcrbnfdyfn53hm2wr0rf3bsvdl5646"))))
+ (base32 "0p1bf6ndcssqh0ic828ggwhzhm67mzj3ffq6043v0fvc1fhn3f7y"))))
(build-system python-build-system)
(arguments
;; FIXME: some tests do not return and time out. Some tests fail because
@@ -8072,14 +8072,14 @@ functions like pickle, json or PyYAML module.")
(define-public python-pathlib2
(package
(name "python-pathlib2")
- (version "2.3.6")
+ (version "2.3.7.post1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pathlib2" version))
(sha256
(base32
- "0psyg60vk8wca473djrh0v9gb853z8wcawi8im5dyg00amawp2vx"))))
+ "0hf62d0lsf37vnr5fxqp5rfn85njgsr45j4rw71w10wbi6nyvq4z"))))
(build-system python-build-system)
(propagated-inputs
(list python-scandir python-six))
@@ -9379,15 +9379,23 @@ the GObject Introspection bindings to libnotify for non-GTK applications.")
(define-public python-beautifulsoup4
(package
(name "python-beautifulsoup4")
- (version "4.10.0")
+ (version "4.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "beautifulsoup4" version))
(sha256
(base32
- "14c8z4gh9bi38agx9ls8ym5rscc02pc6f6hmliaqk08xa8yd4fn2"))))
+ "14v68cpfzckfz63n9hnbsm271jvzvxscyijz83mhha7gcmdsb6md"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs
+ (list python-pytest))
(propagated-inputs
(list python-soupsieve python-html5lib python-lxml))
(home-page