aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-05 15:49:46 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:01 +0000
commitc7f304253f1b0d3a842b6c59201baca7724e1c21 (patch)
treeeb880dedd634c3aac752c6e85e41b2929750a683 /gnu/packages/python-web.scm
parent6d13c785fc49171027b3baabab9c6fdb93dd422c (diff)
downloadguix-c7f304253f1b0d3a842b6c59201baca7724e1c21.tar
guix-c7f304253f1b0d3a842b6c59201baca7724e1c21.tar.gz
gnu: python-requests-toolbelt: Update to 1.0.0.
* gnu/packages/python-web.scm (python-requests-toolbelt): Update to 1.0.0. [build-system]: Swap to pyproject-build-system. [phases]{delete-problematic-tests}: Move logic to <tests-flags. [native-inputs]: Add python-pyopenssl, python-setuptools, python-trustme, and python-wheel. Change-Id: Ie8a9063a53e154b421675d7ee5463861e577111b
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm42
1 files changed, 25 insertions, 17 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 764dd68092..d1e64648cd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3876,25 +3876,33 @@ portions of your testing code.")
(define-public python-requests-toolbelt
(package
(name "python-requests-toolbelt")
- (version "0.9.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "requests-toolbelt" version))
- (sha256
- (base32
- "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
- (build-system python-build-system)
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests-toolbelt" version))
+ (sha256
+ (base32 "1ijvip427ki177ycrblcn1mfgsq7ixzpvqqfvidjn0a7s2is10bn"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'delete-problematic-tests
- (lambda _
- ;; Fails because of expired certificate.
- (delete-file "tests/test_x509_adapter.py")
- ;; Fails due to networking (socket.gaierror: [Errno -2]
- ;; Name or service not known).
- (delete-file "tests/test_multipart_encoder.py"))))))
+ (list
+ #:test-flags
+ ;; Requiring networking or fail due not valid certs: AttributeError:
+ ;; 'MockHTTPResponse' object has no attribute 'close'
+ #~(list "-k" (string-append "not test_dump_all"
+ " and not test_dump_response"
+ " and not test_prepared_request_override_base"
+ " and not test_prepared_request_with_base"
+ " and not test_request_override_base"
+ " and not test_request_with_base"))))
(native-inputs
- (list python-betamax python-mock python-pytest))
+ (list python-betamax
+ python-mock
+ python-pyopenssl
+ python-pytest
+ python-setuptools
+ python-trustme
+ python-wheel))
(propagated-inputs
(list python-requests))
(synopsis "Extensions to python-requests")