aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:14 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:49 +0000
commitbc90ab92810df9171d4b706b6327370fdca34d0b (patch)
tree18622f7acef3fcc204444696a35d866917ee11ee /gnu/packages/python-web.scm
parent80a0bd2586f6b9e5ca189f5e32ddf111a5d880be (diff)
downloadguix-bc90ab92810df9171d4b706b6327370fdca34d0b.tar
guix-bc90ab92810df9171d4b706b6327370fdca34d0b.tar.gz
gnu: python-apiron: Move to pyproject-build-system.
* gnu/packages/python-web.scm (python-apiron): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Replace field with <#:test-flags>. Change-Id: I04bb9739b6356fd50fc07ae54838764d51ed22d6 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9752c2b0a8..bfc0a02e01 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3637,16 +3637,9 @@ WebSocket usage in Python programs.")
(uri (pypi-uri "apiron" version))
(sha256
(base32 "1qwbqn47sf0aqznj1snbv37v8ijx476qqkjf5l9pac7xjkxsr8qk"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "--cov" "-k"
- ;; This test tries to connect to the internet.
- "not test_call"))))))
+ (list #:test-flags '(list "-k" "not test_call")))
(propagated-inputs
(list python-requests))
(native-inputs