aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-27 12:13:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-27 12:48:41 +0200
commit20c5e2f4ef49d7797101d800af1cc88d8be0818e (patch)
tree910bc0dc3761a7cb5c006ba077b80c05e000ee84 /gnu/packages/python-web.scm
parenteba8a00d84232fb8bed441c4e2b66e74bf0e2098 (diff)
downloadguix-20c5e2f4ef49d7797101d800af1cc88d8be0818e.tar
guix-20c5e2f4ef49d7797101d800af1cc88d8be0818e.tar.gz
gnu: python-urllib3: Update to 1.24.1.
* gnu/packages/python-web.scm (python-urllib3): Update to 1.24.1. [native-inputs]: Remove python-nose, add python-pytest. [propagated-inputs]: Add python-pysocks. [home-page]: Update home-page url.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 632de6260e..d81a7550fe 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1416,29 +1416,30 @@ authenticated session objects providing things like keep-alive.")
(define-public python-urllib3
(package
(name "python-urllib3")
- (version "1.23")
+ (version "1.24.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "urllib3" version))
(sha256
(base32
- "1bvbd35q3zdcd7gsv38fwpizy7p06dr0154g5gfybrvnbvhwb2m6"))))
+ "08lwd9f3hqznyf32vnzwvp87pchx062nkbgyrf67rwlkgj0jk5fy"))))
(build-system python-build-system)
(arguments `(#:tests? #f))
(native-inputs
`(;; some packages for tests
- ("python-nose" ,python-nose)
("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
("python-tornado" ,python-tornado)))
(propagated-inputs
`(;; These 5 inputs are used to build urrlib3[secure]
("python-certifi" ,python-certifi)
- ("python-cryptography" ,python-cryptography) ;
+ ("python-cryptography" ,python-cryptography)
("python-idna" ,python-idna)
("python-ipaddress" ,python-ipaddress)
- ("python-pyopenssl" ,python-pyopenssl)))
- (home-page "https://urllib3.readthedocs.org/")
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pysocks" ,python-pysocks)))
+ (home-page "https://urllib3.readthedocs.io/")
(synopsis "HTTP library with thread-safe connection pooling")
(description
"Urllib3 supports features left out of urllib and urllib2 libraries. It