aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-10-27 20:37:30 +0100
committerChristopher Baines <mail@cbaines.net>2018-11-20 19:48:02 +0000
commit9c98d588c2e20fe7434b4ad74c16abbbb28eeb88 (patch)
treeb55609c5771817120984ec65711aa9ee14f3c260 /gnu/packages/python-web.scm
parent90b9c5adea950c7daff3ab14e69601dc78803d6d (diff)
downloadguix-9c98d588c2e20fe7434b4ad74c16abbbb28eeb88.tar
guix-9c98d588c2e20fe7434b4ad74c16abbbb28eeb88.tar.gz
gnu: Add python-slimit.
* gnu/packages/python-web.scm (python-slimit, python2-slimit): New variables.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 161fe6eac2..55b8942ac9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1983,6 +1983,31 @@ transfers.")
`(("python2-futures" ,python2-futures)
,@(package-native-inputs base))))))
+(define-public python-slimit
+ (package
+ (name "python-slimit")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "slimit" version ".zip"))
+ (sha256
+ (base32
+ "02vj2x728rs1127q2nc27frrqra4fczivnb7gch6n5lzi7pxqczl"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (propagated-inputs
+ `(("python-ply" ,python-ply)))
+ (home-page "https://slimit.readthedocs.io/")
+ (synopsis "JavaScript minifier, parser and lexer written in Python")
+ (description
+ "SlimIt is a JavaScript minifier written in Python. It compiles
+JavaScript into more compact code so that it downloads and runs faster.
+SlimIt also provides a library that includes a JavaScript parser, lexer,
+pretty printer and a tree visitor.")
+ (license license:expat)))
+
(define-public python-flask-restful
(package
(name "python-flask-restful")