aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-05-23 10:06:25 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2018-05-25 10:36:43 +0200
commit961bcdf5aca36bd8d1fcd856a569fedd10cb91c5 (patch)
tree7ebd261b15a13b03d44f812c7984ddfe5043cf31 /gnu/packages/python-web.scm
parent1ceca46b0605426885caf4f7f7321203261a4789 (diff)
downloadguix-961bcdf5aca36bd8d1fcd856a569fedd10cb91c5.tar
guix-961bcdf5aca36bd8d1fcd856a569fedd10cb91c5.tar.gz
gnu: Add python-google-api-client.
* gnu/packages/python-web.scm (python-google-api-client): New variable, (python2-google-api-client): new variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index dc1f9a15ac..4868baa928 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2624,3 +2624,30 @@ name resolutions asynchronously.")
(description "@code{yarl} module provides handy @code{URL} class
for URL parsing and changing.")
(license license:asl2.0)))
+
+(define-public python-google-api-client
+ (package
+ (name "python-google-api-client")
+ (version "1.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "google-api-python-client" version))
+ (sha256
+ (base32
+ "1wpbbbxfpy9mwxdy3kn352cb590ladv574j1aa2l4grjdqw3ln05"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; tests require internet access
+ (native-inputs
+ `(("python-httplib2" ,python-httplib2)
+ ("python-six" ,python-six)
+ ("python-oauth2client" ,python-oauth2client)
+ ("python-uritemplate" ,python-uritemplate)))
+ (home-page "https://github.com/google/google-api-python-client")
+ (synopsis "Core Python library for accessing Google APIs")
+ (description "Python client library for Google's discovery based APIs")
+ (license license:asl2.0)))
+
+(define-public python2-google-api-client
+ (package-with-python2 python-google-api-client))