aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-04-23 00:01:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-05-11 11:54:40 +0200
commit85ccc0c281d8ebbe5f08b978925be7eed557284a (patch)
tree27ac0af9f215adc0abffc7c69902ee5d1d950d11 /gnu/packages/python-web.scm
parentbbc8c36fce6f83f3112405d5bec143eb2342b38c (diff)
downloadguix-85ccc0c281d8ebbe5f08b978925be7eed557284a.tar
guix-85ccc0c281d8ebbe5f08b978925be7eed557284a.tar.gz
gnu: Add python-pycares.
* gnu/packages/python-web.scm (python-pycares): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6e8d9ab954..9105afeb37 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
+;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2511,3 +2512,23 @@ protocols, it supports features like HTTP keep-alive, reget, throttling and
more.")
(license license:lgpl2.1+)))
+(define-public python-pycares
+ (package
+ (name "python-pycares")
+ (version "2.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycares" version))
+ (sha256
+ (base32
+ "0h4fxw5drrhfyslzmfpljk0qnnpbhhb20hnnndzahhbwylyw1x1n"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;tests require internet access
+ (home-page "http://github.com/saghul/pycares")
+ (synopsis "Python interface for @code{c-ares}")
+ (description "@code{pycares} is a Python module which provides an
+interface to @code{c-ares}, a C library that performs DNS requests and
+name resolutions asynchronously.")
+ (license license:expat)))