aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
commit839167ff9d74fc490b32f6a197591964f73b65e5 (patch)
treed193bfad7c9ef5597c5cd7d2ea25fd007d01f88a /gnu/packages/python-web.scm
parent27c1df05a866b639a61e16d48b3f2da8fa5eb767 (diff)
parent030c912616c8ee1595218e304460041bcb4f1ceb (diff)
downloadguix-839167ff9d74fc490b32f6a197591964f73b65e5.tar
guix-839167ff9d74fc490b32f6a197591964f73b65e5.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 13 insertions, 19 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 494fbe7999..1230f70572 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1061,13 +1061,13 @@ facilities for defining, registering and looking up components.")
(define-public python-ndg-httpsclient
(package
(name "python-ndg-httpsclient")
- (version "0.5.0")
+ (version "0.5.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "ndg_httpsclient" version))
(sha256
(base32
- "12q8rjvsvjphj6lvvcka2izdjr36a5lgkygajwx6p4wh0x1za2f0"))))
+ "0412b7i1s4vj7lz9r72nmb28h9syd4q2x89bdirkkc3a6z8awbyp"))))
(build-system python-build-system)
(arguments
'(;; The tests appear to require networking.
@@ -1076,9 +1076,9 @@ facilities for defining, registering and looking up components.")
`(("python-pyopenssl" ,python-pyopenssl)))
(synopsis "HTTPS support for Python's httplib and urllib2")
(description "This is a HTTPS client implementation for httplib and urllib2
-based on PyOpenSSL. PyOpenSSL provides a more fully featured SSL implementation
-over the default provided with Python and importantly enables full verification
-of the SSL peer.")
+based on PyOpenSSL. PyOpenSSL provides a more fully-featured SSL implementation
+over the default provided with Python and, importantly, enables full
+verification of the SSL peer.")
(home-page "https://github.com/cedadev/ndg_httpsclient/")
(license license:bsd-3)))
@@ -1350,29 +1350,23 @@ Amazon Web Services (AWS) API.")
(define-public python-wsgiproxy2
(package
(name "python-wsgiproxy2")
- (version "0.4.2")
+ (version "0.4.4")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "WSGIProxy2" version ".zip"))
+ (uri (pypi-uri "WSGIProxy2" version ".tar.gz"))
(sha256
(base32
- "13kf9bdxrc95y9vriaz0viry3ah11nz4rlrykcfvb8nlqpx3dcm4"))))
+ "16532rjc94h3w74x52jfckf3yzsp8h6z34522jk4xgjy82hpnd7r"))))
(build-system python-build-system)
- (arguments
- '(;; Wsgiproxy2's test suite requires Restkit, which does not yet fully
- ;; support Python 3:
- ;; https://github.com/benoitc/restkit/issues/140
- #:tests? #f))
(native-inputs
- `(("unzip" ,unzip)
- ("python-nose" ,python-nose)
- ("python-coverage" ,python-coverage)))
+ `(("python-webtest" ,python-webtest)))
(propagated-inputs
- `(("python-six" ,python-six)
+ `(("python-requests" ,python-requests)
+ ("python-six" ,python-six)
+ ("python-urllib3" ,python-urllib3)
("python-webob" ,python-webob)))
- (home-page
- "https://github.com/gawel/WSGIProxy2/")
+ (home-page "https://github.com/gawel/WSGIProxy2/")
(synopsis "WSGI Proxy with various http client backends")
(description "WSGI turns HTTP requests into WSGI function calls.
WSGIProxy turns WSGI function calls into HTTP requests.