aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 03:44:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 11:46:08 +0200
commit79374801d08c8b3e0df264340fd7212a3dac10ab (patch)
tree7ce8c938ef3b1e962d0044111c6d328c69b68308 /gnu/packages/python-web.scm
parent932839ff124ff3b0dd3070914fb1c5beec69bf32 (diff)
downloadguix-79374801d08c8b3e0df264340fd7212a3dac10ab.tar
guix-79374801d08c8b3e0df264340fd7212a3dac10ab.tar.gz
gnu: python-flask-login: Don't use unstable tarball.
* gnu/packages/python-web.scm (python-flask-login)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6df33fe41d..e3de0a0824 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2056,13 +2056,13 @@ It comes with safe defaults and easily configurable options.")
(version "0.4.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/maxcountryman/flask-login/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/maxcountryman/flask-login.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1pdqp7a2gyb7k06xda004x0fi2w66s6kn2i0ndkqndmg12d83f9w"))))
+ (base32 "0sjbmk8m4mmd9g99n6c6lx9nv2jwwqp6qsqhl945w2m0f1sknwdh"))))
(arguments
;; Tests fail PEP8 compliance. See:
;; https://github.com/maxcountryman/flask-login/issues/340