aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-24 15:56:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-24 15:57:56 +0100
commit60667159d329b1f07d01b5bd03e3b289208ad406 (patch)
tree2c55dcb096d02ed14dd8b87b78770d8ce924f77d /gnu/packages/python-web.scm
parent68f2e552060a9c94f1eb56246e7f14103ca119dc (diff)
downloadguix-60667159d329b1f07d01b5bd03e3b289208ad406.tar
guix-60667159d329b1f07d01b5bd03e3b289208ad406.tar.gz
gnu: python-pycurl: Fix FTBFS from 7b844100464633db5455a3931858bb57c9e529e6.
* gnu/packages/python-web.scm (python-pycurl)[arguments]: Add phase 'configure-tls-backend'.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 03db842531..8957d28268 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -443,7 +443,15 @@ C, yielding parse times that can be a thirtieth of the html5lib parse times.")
(arguments
;; The tests attempt to access external web servers, so we cannot run
;; them. Furthermore, they are skipped altogether when using Python 2.
- '(#:tests? #f))
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'configure-tls-backend
+ (lambda _
+ ;; XXX: PycURL fails to automatically determine which TLS
+ ;; backend to use when cURL is built with --disable-static.
+ ;; See setup.py and <https://github.com/pycurl/pycurl/pull/147>.
+ (setenv "PYCURL_SSL_LIBRARY" "gnutls")
+ #t)))))
(native-inputs
`(("python-nose" ,python-nose)
("python-bottle" ,python-bottle)))