aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-04-23 00:12:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-05-11 11:54:41 +0200
commitcef6dc646eaacbfd5800b134f426ccc41419d1b8 (patch)
treef530f8538b009cca14ddcddf02f1c98963fd4c5c /gnu/packages/python-crypto.scm
parent2528f3c867b1e180136961376ed0136103cb6a47 (diff)
downloadguix-cef6dc646eaacbfd5800b134f426ccc41419d1b8.tar
guix-cef6dc646eaacbfd5800b134f426ccc41419d1b8.tar.gz
gnu: Add python-base58.
* gnu/packages/python-crypto.scm (python-base58): New variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index cdd74d3053..1f5da022f0 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
+;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,6 +50,26 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-base58
+ (package
+ (name "python-base58")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "base58" version))
+ (sha256
+ (base32
+ "0lgnk7ycdxwhk2bkygl30nsks56bvrdj79ix76iv965pz808pzn5"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pyhamcrest" ,python-pyhamcrest)))
+ (home-page "https://github.com/keis/base58")
+ (synopsis "Base58 and Base58Check implementation")
+ (description "Base58 and Base58Check implementation compatible
+with what is used by the Bitcoin network.")
+ (license license:expat)))
+
(define-public python-bcrypt
(package
(name "python-bcrypt")