aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-12 17:28:02 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:10 +0100
commitea8759f8b1d2bdf45eb7883dec5bb2277534e56d (patch)
treef618b7f13e29538350766e662e1226995da5a581 /gnu/packages/python-crypto.scm
parent229d39fa4a0f163f8bb8963698543c5c5eb3fe13 (diff)
downloadguix-ea8759f8b1d2bdf45eb7883dec5bb2277534e56d.tar
guix-ea8759f8b1d2bdf45eb7883dec5bb2277534e56d.tar.gz
gnu: python-pyopenssl: Update to 20.0.0.
* gnu/packages/python-crypto.scm (python-pyopenssl): Update to 20.0.0.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 0e4edb7d23..6d0f0c795d 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -569,14 +569,14 @@ message digests and key derivation functions.")
(define-public python-pyopenssl
(package
(name "python-pyopenssl")
- (version "19.1.0")
+ (version "20.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyOpenSSL" version))
(sha256
(base32
- "01wmsq6w0frzbr3zps4ga9kmqjidp2h317jwpq1g9ah24r5lj94s"))))
+ "1i8ab5zn9i9iq2ksizp3rd42v157kacddzz88kviqw3kpp68xw4j"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -588,7 +588,7 @@ message digests and key derivation functions.")
;; PyOpenSSL runs tests against a certificate with a fixed
;; expiry time. To ensure successful builds in the future,
;; set the time to roughly the release date.
- (invoke "faketime" "2019-01-01" "py.test" "-v" "-k"
+ (invoke "faketime" "2020-12-01" "py.test" "-v" "-k"
(string-append
;; This test tries to look up certificates from
;; the compiled-in default path in OpenSSL, which