aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-07 10:24:14 -0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-09 14:48:00 +0300
commit960dafce5cede173b83a47d6b65233eb87230aaf (patch)
treeeaba4d1f20b05f8b0ad7f0f8d211d81b0d028cca /gnu/packages/python-crypto.scm
parent7d7ad3c946897014cc1ccb7094382b21a8f7b45c (diff)
downloadguix-960dafce5cede173b83a47d6b65233eb87230aaf.tar
guix-960dafce5cede173b83a47d6b65233eb87230aaf.tar.gz
gnu: Add python-trustme.
* gnu/packages/python-crypto.scm (python-trustme): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index f3f104df8d..c1ff92c452 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages swig)
@@ -1349,6 +1351,42 @@ items and collections, editing items, locking and unlocking collections
(asynchronous unlocking is also supported).")
(license license:bsd-3)))
+(define-public python-trustme
+ (package
+ (name "python-trustme")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trustme" version))
+ (sha256
+ (base32 "0v3vr5z6apnfmklf07m45kv5kaqvm6hxrkaqywch57bjd2siiywx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-more-itertools" ,python-more-itertools)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-service-identity" ,python-service-identity)
+ ("python-zipp" ,python-zipp)))
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)))
+ (home-page "https://github.com/python-trio/trustme")
+ (synopsis "Fake a certificate authority for tests")
+ (description
+ "@code{trustme} is a tiny Python package that does one thing: it gives you
+a fake certificate authority (CA) that you can use to generate fake TLS certs to
+use in your tests.")
+ ;; Either license applies.
+ (license (list license:expat license:asl2.0))))
+
(define-public python-jeepney
(package
(name "python-jeepney")