aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2020-08-05 12:44:15 +0200
committerJelle Licht <jlicht@fsfe.org>2020-08-05 15:09:30 +0200
commit4764e83ce9b7c73e66325226a4690ec6c1fc487c (patch)
treeb1424a0ad6f4d5b032f5ccb0d81f47639d720ca5 /gnu/packages/python-crypto.scm
parent43708b60b7da01444630c46c16df0bdf067501a8 (diff)
downloadguix-4764e83ce9b7c73e66325226a4690ec6c1fc487c.tar
guix-4764e83ce9b7c73e66325226a4690ec6c1fc487c.tar.gz
gnu: python-m2crypto: Add swig as native-input.
* gnu/packages/python-crypto.scm (python-m2crypto)[native-inputs]: Add swig.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index ecf82f2078..f3f104df8d 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module ((guix licenses) #:prefix license:)
@@ -1014,6 +1015,7 @@ in userspace)
(base32 "09yirf3w77w6f49q6nxhrjm9c3a4y9s30s1k09chqrw8zdgx8sjc"))))
(build-system python-build-system)
(inputs `(("openssl" ,openssl)))
+ (native-inputs `(("swig" ,swig)))
(home-page "https://gitlab.com/m2crypto/m2crypto")
(synopsis "Python crypto and TLS toolkit")
(description "@code{M2Crypto} is a complete Python wrapper for OpenSSL