aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-21 04:57:29 -0400
committerMark H Weaver <mhw@netris.org>2018-04-21 05:02:52 -0400
commitc52872bfc418c6b2273f973dff8003ca9e062792 (patch)
tree4184a250e6d8363b3901aa2abe6910ff08ce08d4 /gnu/packages/python-crypto.scm
parent65bb22796f854cbc3eae053a80b1d64365dad376 (diff)
parent3fe49e50153fec1dabac35e262a0888044f79aa6 (diff)
downloadguix-c52872bfc418c6b2273f973dff8003ca9e062792.tar
guix-c52872bfc418c6b2273f973dff8003ca9e062792.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm70
1 files changed, 63 insertions, 7 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index fb8575cb78..69b6ffd3f4 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,37 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-bcrypt
+ (package
+ (name "python-bcrypt")
+ (version "3.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bcrypt" version))
+ (sha256
+ (base32
+ "13cyrnqwkhc70rs6dg65z4yrrr3dc42fhk11804fqmci9hvimvb7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pycparser" ,python-pycparser)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-cffi" ,python-cffi)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/pyca/bcrypt/")
+ (synopsis
+ "Modern password hashing library")
+ (description
+ "Bcrypt is a Python module which provides a password hashing method based
+on the Blowfish password hashing algorithm, as described in
+@url{http://static.usenix.org/events/usenix99/provos.html,\"A Future-Adaptable
+Password Scheme\"} by Niels Provos and David Mazieres.")
+ (license license:asl2.0)))
+
+(define-public python2-bcrypt
+ (package-with-python2 python-bcrypt))
+
(define-public python-passlib
(package
(name "python-passlib")
@@ -122,21 +154,18 @@ John the Ripper).")
(define-public python-paramiko
(package
(name "python-paramiko")
- (version "2.1.5")
+ (version "2.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "paramiko" version))
(sha256
(base32
- "1pf0zxzhgyy4avby3ajg5hp18b0d8iirbkdfw53z0h6w611bp0wk"))))
+ "1wx4s95i2cdh8hhi1c3jb8lzk71jifa3z9wjfsx905y7lrsngqrk"))))
(build-system python-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (zero? (system* "python" "test.py")))))))
+ `(;; FIXME: Tests require many unpackaged libraries, see dev-requirements.txt.
+ #:tests? #f))
(propagated-inputs
`(("python-pyasn1" ,python-pyasn1)
("python-cryptography" ,python-cryptography)))
@@ -762,3 +791,30 @@ in userspace)
(define-public python2-pycryptodome
(package-with-python2 python-pycryptodome))
+
+(define-public python-m2crypto
+ (package
+ (name "python-m2crypto")
+ (version "0.29.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "M2Crypto" version))
+ (sha256
+ (base32 "1h16gpilrnlzc0iyj1mnd1iqh8wchzjsxjqw9n344glimg2s5zm0"))))
+ (build-system python-build-system)
+ (inputs `(("openssl" ,openssl)))
+ (propagated-inputs `(("python-typing" ,python-typing)))
+ (home-page "https://gitlab.com/m2crypto/m2crypto")
+ (synopsis "Python crypto and TLS toolkit")
+ (description "@code{M2Crypto} is a complete Python wrapper for OpenSSL
+featuring RSA, DSA, DH, EC, HMACs, message digests, symmetric ciphers
+(including AES); TLS functionality to implement clients and servers; HTTPS
+extensions to Python's httplib, urllib, and xmlrpclib; unforgeable HMAC'ing
+AuthCookies for web session management; FTP/TLS client and server; S/MIME;
+M2Crypto can also be used to provide TLS for Twisted. Smartcards supported
+through the Engine interface.")
+ (license license:expat)))
+
+(define-public python2-m2crypto
+ (package-with-python2 python-m2crypto))