aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 15:34:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 15:34:23 +0300
commitd6fedf6bf73c5875b6f3d75f1a3349e7ccef43c5 (patch)
treef0edbff6193baff0c69281987224e0d3ca52db3c /gnu/packages/python-check.scm
parentcd005bfea5646bff9134385b2a04991cdee52230 (diff)
downloadguix-d6fedf6bf73c5875b6f3d75f1a3349e7ccef43c5.tar
guix-d6fedf6bf73c5875b6f3d75f1a3349e7ccef43c5.tar.gz
gnu: python-pytest-vcr: Fix integration with pytest-5.
* gnu/packages/python-check.scm (python-pytest-vcr): Update to 1.0.2-1.4d6c7b3.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm61
1 files changed, 32 insertions, 29 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 200bce6ced..09eb253f06 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -126,35 +126,38 @@ interactions, which will update them to correspond to the new API.")
(license license:expat)))
(define-public python-pytest-vcr
- (package
- (name "python-pytest-vcr")
- (version "1.0.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ktosiek/pytest-vcr")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1i6fin91mklvbi8jzfiswvwf1m91f43smpj36a17xrzk4gisfs6i"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "tests/"))))))
- (propagated-inputs
- `(("python-pytest" ,python-pytest)
- ("python-vcrpy" ,python-vcrpy)))
- (home-page "https://github.com/ktosiek/pytest-vcr")
- (synopsis "Plugin for managing VCR.py cassettes")
- (description
- "Plugin for managing VCR.py cassettes.")
- (license license:expat)))
+ ;; This commit fixes integration with pytest-5
+ (let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")
+ (revision "1"))
+ (package
+ (name "python-pytest-vcr")
+ (version (git-version "1.0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ktosiek/pytest-vcr")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yk988zi0la6zpcm3fff0mxf942di2jiymrfqas19nyngj5ygaqs"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "tests/"))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-vcrpy" ,python-vcrpy)))
+ (home-page "https://github.com/ktosiek/pytest-vcr")
+ (synopsis "Plugin for managing VCR.py cassettes")
+ (description
+ "Plugin for managing VCR.py cassettes.")
+ (license license:expat))))
(define-public python-pytest-checkdocs
(package