aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:51:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:51:10 +0300
commit3f4bfc3899849d20e4f6181ab4df1c8b0e3285e2 (patch)
treef0e1963fefe03580e0c40332b7f024376c714107 /gnu/packages/python-check.scm
parente297edbfe5b1d711677a93bcab80e47748c66cde (diff)
downloadguix-3f4bfc3899849d20e4f6181ab4df1c8b0e3285e2.tar
guix-3f4bfc3899849d20e4f6181ab4df1c8b0e3285e2.tar.gz
gnu: Add python-pytest-aiohttp.
* gnu/packages/python-check.scm (python-pytest-aiohttp): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e3f0f6acbe..2e3cfe05c5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -412,6 +412,27 @@ rounds that are calibrated to the chosen timer.")
service processes for your tests with pytest.")
(license license:expat)))
+(define-public python-pytest-aiohttp
+ (package
+ (name "python-pytest-aiohttp")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-aiohttp" version))
+ (sha256
+ (base32
+ "0kx4mbs9bflycd8x9af0idcjhdgnzri3nw1qb0vpfyb3751qaaf9"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-aiohttp" ,python-aiohttp)))
+ (home-page "https://github.com/aio-libs/pytest-aiohttp/")
+ (synopsis "Pytest plugin for aiohttp support")
+ (description "This package provides a pytest plugin for aiohttp support.")
+ (license license:asl2.0)))
+
(define-public python-pytest-flask
(package
(name "python-pytest-flask")