aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:15:19 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:07 +0000
commitc6d8655799eebd08a36763a4767a20f885fcd0cd (patch)
tree2cb54dd9795b9fc2de12216904b424577d3744ed /gnu/packages/python-build.scm
parent495a65cd9aa4a4c9fa3ef6ce28d4beb213464cc0 (diff)
downloadguix-c6d8655799eebd08a36763a4767a20f885fcd0cd.tar
guix-c6d8655799eebd08a36763a4767a20f885fcd0cd.tar.gz
gnu: Add python-pypa-installer.
* gnu/packages/python-build.scm (python-pypa-installer): New variable. Change-Id: Ida794a6dd9a4da62c842703139a95983580bd935
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index e18fe27fb1..89352d9026 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -531,6 +531,30 @@ any dependency management. It aims to keep dependencies to a minimum, in
order to make bootstrapping easier.")
(license license:expat)))
+;; There are quite a few amount of Python installers in the wild we need the
+;; one from PyPa team.
+(define-public python-pypa-installer
+ (package
+ (name "python-pypa-installer")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "installer" version))
+ (sha256
+ (base32 "0cdnqh3a3amw8k4s1pzfjh0hpvzw4pczgl702s1b16r82qqkwvd2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ; Depends on pytest, which we cannot import into this module.
+ (native-inputs
+ (list python-flit-core))
+ (home-page "https://installer.readthedocs.io/")
+ (synopsis "low-level library for installing from a Python wheel distribution")
+ (description
+ "This package provides a library for installing Python wheels.")
+ (license license:expat)))
+
(define-public python-poetry-core-1.0
(package
(name "python-poetry-core")