aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-25 00:00:41 -0400
committerLeo Famulari <leo@famulari.name>2017-06-25 00:03:18 -0400
commit33717a17aab65785d609062f68ff59bcb0543cbc (patch)
tree3c598f5de845fd1a695d5952ecf80f81907b559e /gnu/packages/photo.scm
parentd17e085a59534a333cb8db028579fd0e6ec7f89b (diff)
downloadguix-33717a17aab65785d609062f68ff59bcb0543cbc.tar
guix-33717a17aab65785d609062f68ff59bcb0543cbc.tar.gz
gnu: perl-image-exiftool: Update to 10.55.
* gnu/packages/photo.scm (perl-image-exiftool): Update to 10.55. [arguments]: Use modify-phases syntax.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 062f4b9d45..3effc181d3 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -177,7 +177,7 @@ MTP, and much more.")
(define-public perl-image-exiftool
(package
(name "perl-image-exiftool")
- (version "10.40")
+ (version "10.55")
(source (origin
(method url-fetch)
(uri (string-append
@@ -185,20 +185,20 @@ MTP, and much more.")
version ".tar.gz"))
(sha256
(base32
- "1p05d9k94win8a24cr7lsllb6wjl3dagsmdbcxzv6f68z7i1jdly"))))
+ "0z8zwjjfvyllnhsafhddbybywpgqv0pl1dbn1g034cs27yj836q2"))))
(build-system perl-build-system)
(arguments
- '(#:phases (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure the 'exiftool' commands finds the library.
- ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
- (let* ((out (assoc-ref outputs "out"))
- (pm (find-files out "^ExifTool\\.pm$"))
- (lib (dirname (dirname (car pm)))))
- (wrap-program (string-append out "/bin/exiftool")
- `("PERL5LIB" prefix (,lib)))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure the 'exiftool' commands finds the library.
+ ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
+ (let* ((out (assoc-ref outputs "out"))
+ (pm (find-files out "^ExifTool\\.pm$"))
+ (lib (dirname (dirname (car pm)))))
+ (wrap-program (string-append out "/bin/exiftool")
+ `("PERL5LIB" prefix (,lib)))))))))
(home-page "http://search.cpan.org/dist/Image-ExifTool")
(synopsis "Program and Perl library to manipulate EXIF and other metadata")
(description "This package provides the @code{exiftool} command and the