aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:14 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:39 +0200
commit924a4b0c66bfe2e8c5f2da83e77dc92853637a24 (patch)
tree45692f2688ba04be4c791900ee1f36dbec8459ec /gnu/packages/photo.scm
parente7e87b40464c6751d61aa20a8872f16321199201 (diff)
downloadguix-924a4b0c66bfe2e8c5f2da83e77dc92853637a24.tar
guix-924a4b0c66bfe2e8c5f2da83e77dc92853637a24.tar.gz
gnu: photo: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/photo.scm (rapid-photo-downloader)[inputs]: Add 'bash-minimal'. (perl-image-exiftool)[inputs]: Likewise. (entangle)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I843c7530ae24969660a00c0da7754e51475ea00d
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 6088ae9aca..b6931c6776 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -117,7 +117,8 @@
(native-inputs
(list file intltool gobject-introspection))
(inputs
- `(("gdk-pixbuf" ,gdk-pixbuf)
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("gdk-pixbuf" ,gdk-pixbuf)
("gexiv2" ,gexiv2)
("gst-libav" ,gst-libav)
("gst-plugins-base" ,gst-plugins-base)
@@ -331,6 +332,7 @@ MTP, and much more.")
(lib (dirname (dirname (car pm)))))
(wrap-program (string-append #$output "/bin/exiftool")
`("PERL5LIB" prefix (,lib)))))))))
+ (inputs (list bash-minimal))
(home-page "https://metacpan.org/release/Image-ExifTool")
(synopsis "Program and Perl library to manipulate EXIF and other metadata")
(description "This package provides the @code{exiftool} command and the
@@ -727,7 +729,8 @@ such as Batch image processing.")
perl
pkg-config))
(inputs
- (list gdk-pixbuf
+ (list bash-minimal
+ gdk-pixbuf
gexiv2
gst-plugins-base
gstreamer