aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-06-22 00:19:13 -0300
committerMarius Bakke <marius@gnu.org>2020-06-24 22:10:58 +0200
commitc53d529f1da483fbbd5ebde7e39a7d15b90b55ae (patch)
tree55efc9374bca351a5a3eb0ba687d4271788b9e2d /gnu/packages/photo.scm
parentcdf6a11880b2e745f0dc8fd9af116ff9ce122fc1 (diff)
downloadguix-c53d529f1da483fbbd5ebde7e39a7d15b90b55ae.tar
guix-c53d529f1da483fbbd5ebde7e39a7d15b90b55ae.tar.gz
gnu: Add photoflare.
* gnu/packages/photo.scm (photoflare): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 890035f0c7..75bbc45380 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -31,6 +31,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -556,6 +557,50 @@ and enhance them.")
(license (list license:gpl3+ ;; Darktable itself.
license:lgpl2.1+)))) ;; Rawspeed library.
+(define-public photoflare
+ (package
+ (name "photoflare")
+ (version "1.6.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/photoflare/photoflare")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a394324h7ds567z3i3pw6kkii78n4qwdn129kgkkm996yh03q89"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((magickpp (assoc-ref inputs "graphicsmagick"))
+ (out (assoc-ref outputs "out")))
+ (invoke "qmake"
+ (string-append "INCLUDEPATH += " magickpp
+ "/include/GraphicsMagick")
+ (string-append "PREFIX=" out)
+ "Photoflare.pro")))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("graphicsmagick" ,graphicsmagick)
+ ("libomp" ,libomp)
+ ("qtbase" ,qtbase)))
+ (home-page "https://photoflare.io")
+ (synopsis "Quick, simple but powerful image editor")
+ (description "Photoflare is a cross-platform image editor with an aim
+to balance between powerful features and a very friendly graphical user
+interface. It suits a wide variety of different tasks and users who value a
+more nimble workflow. Features include basic image editing capabilities,
+paint brushes, image filters, colour adjustments and more advanced features
+such as Batch image processing.")
+ (license license:gpl3+)))
+
(define-public hugin
(package
(name "hugin")