aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-13 11:25:24 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-13 11:28:54 +0100
commit4187fe750f128f934bd6030912133d13d19baafd (patch)
tree3d02f64726542f54c55be0a1869efe0534a3ba47 /gnu/packages/perl.scm
parent4de35074833742e45237464bb1727ce1a55f3336 (diff)
downloadguix-4187fe750f128f934bd6030912133d13d19baafd.tar
guix-4187fe750f128f934bd6030912133d13d19baafd.tar.gz
gnu: perl: Build deterministically, and make byproducts deterministic.
With this, a --rounds=2 build passes, and timestamps in POD files can be controlled with 'SOURCE_DATE_EPOCH'. * gnu/packages/patches/perl-deterministic-ordering.patch, gnu/packages/patches/perl-no-build-time.patch, gnu/packages/patches/perl-source-date-epoch.patch: New files. * gnu/packages/perl.scm (perl)[source]: Use them. * gnu-system.am (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8fec270b61..6afe0b73ec 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -47,7 +47,10 @@
"0g5bl8sdpzx9gx2g5jq3py4bj07z2ylk7s1qn0fvsss2yl3hhs8c"))
(patches (map search-patch
'("perl-no-sys-dirs.patch"
- "perl-autosplit-default-time.patch")))))
+ "perl-autosplit-default-time.patch"
+ "perl-source-date-epoch.patch"
+ "perl-deterministic-ordering.patch"
+ "perl-no-build-time.patch")))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f