aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-19 20:37:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 07:13:49 +0200
commit7d475dd4ece966faae71323f309b65314b27a5a3 (patch)
treedcf521d1c2c81d4ffb20eaecb3ee698d96e3f84c /gnu/packages/pdf.scm
parent06dbfb5d197db7502ed65c1019e96f3f02c34b7a (diff)
downloadguix-7d475dd4ece966faae71323f309b65314b27a5a3.tar
guix-7d475dd4ece966faae71323f309b65314b27a5a3.tar.gz
gnu: zathura-djvu: Update to 0.2.8.
* gnu/packages/pdf.scm (zathura-djvu): Update to 0.2.8. [build-system]: Switch to the Meson build system. [arguments]: Trim accordingly. Add a new ‘patch-plugin-directory’ phase.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 77d78bb805..151143aa31 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -384,27 +384,33 @@ using libspectre.")
(define-public zathura-djvu
(package
(name "zathura-djvu")
- (version "0.2.7")
+ (version "0.2.8")
(source (origin
(method url-fetch)
(uri
(string-append "https://pwmt.org/projects/zathura-djvu/download/zathura-djvu-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "1sbfdsyp50qc85xc4458sn4w1rv1qbygdwmcr5kjlfpsmdq98vhd"))))
+ "0axkv1crdxn0z44whaqp2ibkdqcykhjnxk7qzms0dp1b67an9rnh"))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("djvulibre" ,djvulibre)
("zathura" ,zathura)))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- `(#:make-flags (list (string-append "PREFIX=" %output)
- (string-append "PLUGINDIR=" %output "/lib/zathura")
- "CC=gcc")
- #:tests? #f ; Package does not contain tests.
+ `(#:tests? #f ; package does not contain tests
#:phases
- (modify-phases %standard-phases (delete 'configure))))
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-plugin-directory
+ ;; Something of a regression in 0.2.8: the new Meson build system
+ ;; now hard-codes an incorrect plugin directory. Fix it.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "meson.build"
+ (("(install_dir:).*" _ key)
+ (string-append key
+ "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
+ #t)))))
(home-page "https://pwmt.org/projects/zathura-djvu/")
(synopsis "DjVu support for zathura (DjVuLibre backend)")
(description "The zathura-djvu plugin adds DjVu support to zathura