aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
commit961d2ee2695b38503b463d055e9c7edbcc0bf307 (patch)
tree82d9b40477a1d4d88e75a187b2b637a56751480b /gnu/packages/pdf.scm
parent7cf79d7a51ff5dde4fc430fab2296b5f7de08953 (diff)
parentaebba13c0bef5a58697f1a9fe8337967cc01300f (diff)
downloadguix-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar
guix-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index c5001ff086..700968d60a 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -677,26 +677,14 @@ line tools for batch rendering @command{pdfdraw}, rewriting files
(define-public qpdf
(package
(name "qpdf")
- (version "9.1.0")
+ (version "9.1.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/qpdf/qpdf/" version
"/qpdf-" version ".tar.gz"))
(sha256
(base32
- "0ygd80wxcmh613n04x2kmf8wlsl0drxyd5wwdcrm1rzj0xwvpfrs"))
- (modules '((guix build utils)))
- (snippet
- ;; Replace shebang with the bi-lingual shell/Perl trick to remove
- ;; dependency on Perl.
- '(begin
- (substitute* "qpdf/fix-qdf"
- (("#!/usr/bin/env perl")
- "\
-eval '(exit $?0)' && eval 'exec perl -wS \"$0\" ${1+\"$@\"}'
- & eval 'exec perl -wS \"$0\" $argv:q'
- if 0;\n"))
- #t))))
+ "0dj27wb9xg6pg95phbflfvy9rwxn1gh3kc4n175g0pf41r0zrim2"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,perl)