aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2018-04-15 13:05:54 +0300
committerManolis Ragkousis <manolis837@gmail.com>2018-04-15 15:17:21 +0300
commitfdb61400a0588fa281b29a1791090dd6f35f815b (patch)
tree143e2163f383c35c608a40d1afea8b764cfbebff /gnu/packages/patches
parent3b4f3ff7eefa01adafd928c08f1655ea898f0c7e (diff)
downloadguix-fdb61400a0588fa281b29a1791090dd6f35f815b.tar
guix-fdb61400a0588fa281b29a1791090dd6f35f815b.tar.gz
gnu: mupen64plus-video-z64: Fix glew.h location.
* gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/emulators.scm (mupen64plus-video-z64)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch b/gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch
new file mode 100644
index 0000000000..c3fcfbbd0e
--- /dev/null
+++ b/gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch
@@ -0,0 +1,36 @@
+From 21507b3600c616bca7049004eb518cf11f45f299 Mon Sep 17 00:00:00 2001
+From: "Anthony J. Bentley" <anthony@cathet.us>
+Date: Sun, 7 Jun 2015 02:41:28 -0600
+Subject: [PATCH] Correct the path to the GLEW header.
+
+---
+ src/glshader.cpp | 2 +-
+ src/rgl.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/glshader.cpp b/src/glshader.cpp
+index 4729945..a8947ea 100644
+--- a/src/glshader.cpp
++++ b/src/glshader.cpp
+@@ -23,7 +23,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include "rgl_assert.h"
+-#include <glew.h>
++#include <GL/glew.h>
+ #if defined(__MACOSX__)
+ #include <OpenGL/gl.h>
+ #include <OpenGL/glext.h>
+diff --git a/src/rgl.h b/src/rgl.h
+index c15f93f..1748406 100644
+--- a/src/rgl.h
++++ b/src/rgl.h
+@@ -26,7 +26,7 @@
+ #include "rgl_assert.h"
+ #include "rdp.h"
+
+-#include <glew.h>
++#include <GL/glew.h>
+ #if defined(__MACOSX__)
+ #include <OpenGL/gl.h>
+ #elif defined(__MACOS__)