aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-03 22:46:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-04 09:29:24 +0300
commitf473b8f1f7db695dce1ed5b145be501424e76b34 (patch)
treee6e98b2ff582b10ca9178d5559029c5f653b9291 /gnu/packages/patches
parentfa4f95a7c4ebc59f5f91499cd99400fc76e39001 (diff)
downloadguix-f473b8f1f7db695dce1ed5b145be501424e76b34.tar
guix-f473b8f1f7db695dce1ed5b145be501424e76b34.tar.gz
gnu: clisp: Update to 2.49-60.
* gnu/packages/lisp.scm (clisp): Update to 2.49-60. [source]: Download mercurial repository, apply patch. [inputs]: Replace readline@6.2 with readline, add ncurses. [arguments]: Add multiple configure flags. Remove build phase to build in "src" directory. Remove more uses of a timestamp.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/clisp-remove-failing-test.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/patches/clisp-remove-failing-test.patch b/gnu/packages/patches/clisp-remove-failing-test.patch
new file mode 100644
index 0000000000..e44ce80f74
--- /dev/null
+++ b/gnu/packages/patches/clisp-remove-failing-test.patch
@@ -0,0 +1,43 @@
+This test doesn't ever complete or timeout
+
+---
+ tests/socket.tst | 24 ------------------------
+ 1 file changed, 24 deletions(-)
+
+diff --git a/tests/socket.tst b/tests/socket.tst
+index 93c6310..1d976ff 100644
+--- a/tests/socket.tst
++++ b/tests/socket.tst
+@@ -551,30 +551,6 @@ T
+ interfaces))
+ ("0.0.0.0" "127.0.0.1" "0.0.0.0" "127.0.0.1")
+
+-(multiple-value-bind (run args) (cmd-args)
+- (let ((se (socket:socket-server)))
+- (ext:run-program run :arguments (append args (list "-q" "-q" "-x" (format nil "(close (socket:socket-connect ~D))" (socket:socket-server-port se))))
+- :wait nil :input nil :output nil)
+- (unwind-protect
+- (with-open-stream (so (socket:socket-accept se))
+- (list
+- (socket:socket-status so)
+- (write-line "foo" so)
+- (socket:socket-status so)
+- #+macos (handler-case (read-char so)
+- (end-of-file (c)
+- (princ 'read-char) (princ-error c) t))
+- #-macos (check-os-error (read-char so) (:ECONNRESET 104))
+- (null (member (socket:socket-status so) '(:EOF :APPEND)))
+- #+macos (string= (write-line "bar" so) "bar")
+- #-macos (check-os-error (write-line "bar" so) (:EPIPE 32))
+- (null (member (socket:socket-status so) '(:EOF :APPEND)))
+- (handler-case (read-char so)
+- (end-of-file (c)
+- (princ 'read-char) (princ-error c) 'end-of-file))))
+- (socket:socket-server-close se))))
+-(:OUTPUT "foo" :OUTPUT T NIL T NIL END-OF-FILE)
+-
+ ;; https://sourceforge.net/p/clisp/feature-requests/46/
+ (check-os-error (socket:socket-connect 0)
+ #-(or win32 macos) (:ECONNREFUSED 111)
+--
+