aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-11 18:36:17 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-11 18:39:08 +0100
commitab110cae121c1d8e10625690da856e8e6a9f3e65 (patch)
treec8abce0cbf9bc0b138a4d95d5adde0fdeb3aaefb /gnu/packages/patches
parent96f0c5449ac72e484c2911a210751f028024e656 (diff)
downloadguix-ab110cae121c1d8e10625690da856e8e6a9f3e65.tar
guix-ab110cae121c1d8e10625690da856e8e6a9f3e65.tar.gz
gnu: texmacs: Support HiDPI displays on Wayland.
* gnu/packages/patches/texmacs-wayland-hidpi.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/text-editors.scm (texmacs)[source]: Use it. (texmacs-guile3)[source]: Use it. (mogan)[source]: Use it. Change-Id: Ida737433957cb26695bf43538cff4d5d1c8a83c3
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/texmacs-wayland-hidpi.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/texmacs-wayland-hidpi.patch b/gnu/packages/patches/texmacs-wayland-hidpi.patch
new file mode 100644
index 0000000000..decf500125
--- /dev/null
+++ b/gnu/packages/patches/texmacs-wayland-hidpi.patch
@@ -0,0 +1,22 @@
+Author: Danny Milosavljevic <dannym@friendly-machines.com>
+Date: 2024-12-11 18:30:00 CET 2024
+License: gpl3+
+
+diff -ru orig/qsbrdssq407hsajf74z60vp3rhgafjsl-mogan-1.1.1-checkout/src/Texmacs/Texmacs/texmacs.cpp qsbrdssq407hsajf74z60vp3rhgafjsl-mogan-1.1.1-checkout/src/Texmacs/Texmacs/texmacs.cpp
+--- orig/qsbrdssq407hsajf74z60vp3rhgafjsl-mogan-1.1.1-checkout/src/Texmacs/Texmacs/texmacs.cpp 2024-05-10 01:51:55.312256939 +0200
++++ qsbrdssq407hsajf74z60vp3rhgafjsl-mogan-1.1.1-checkout/src/Texmacs/Texmacs/texmacs.cpp 2024-05-10 01:52:43.659909394 +0200
+@@ -685,8 +685,12 @@
+ #ifndef OS_MINGW
+ set_env ("LC_NUMERIC", "POSIX");
+ #ifndef OS_MACOS
+- set_env ("QT_QPA_PLATFORM", "xcb");
+- set_env ("XDG_SESSION_TYPE", "x11");
++ if (get_env ("XDG_SESSION_TYPE") == "wayland") {
++ set_env ("QT_QPA_PLATFORM", "wayland"); QGuiApplication::setAttribute(Qt::AA_DisableHighDpiScaling); QGuiApplication::setAttribute(Qt::AA_UseHighDpiPixmaps);
++ } else {
++ set_env ("QT_QPA_PLATFORM", "xcb");
++ set_env ("XDG_SESSION_TYPE", "x11");
++ }
+ #endif
+ #endif
+ #ifdef MACOSX_EXTENSIONS