aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 15:07:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:52 -0400
commit46e56eb001751d127c38a7a4f5a23dc4cc214453 (patch)
treed11e7b22d5659d552a640633bef6d548d5101918 /gnu/packages/patches
parent0d5746ee7ca337dcc82553ca6dd794b04bb6563d (diff)
downloadguix-46e56eb001751d127c38a7a4f5a23dc4cc214453.tar
guix-46e56eb001751d127c38a7a4f5a23dc4cc214453.tar.gz
gnu: Add orangeduck-mpc.
* gnu/packages/c.scm (orangeduck-mpc): New variable. * gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch b/gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch
new file mode 100644
index 0000000000..f6155517d1
--- /dev/null
+++ b/gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch
@@ -0,0 +1,25 @@
+Upstream status: https://github.com/orangeduck/mpc/pull/160
+
+diff --git a/Makefile b/Makefile
+index 7719acc..fe798c5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -15,7 +15,7 @@ EXAMPLESEXE = $(EXAMPLES:.c=)
+
+ .PHONY: all check clean libs $(DIST)/$(PROJ).pc
+
+-all: $(EXAMPLESEXE) check
++all: $(EXAMPLESEXE) check libs $(DIST)/$(PROJ).pc
+
+ $(DIST):
+ $(MKDIR) $(DIST)
+@@ -65,7 +65,8 @@ install: all
+ install -m755 -t $(DESTDIR)$(PREFIX)/lib $(DIST)/lib*
+ install -m644 -t $(DESTDIR)$(PREFIX)/share/$(PROJ) $(PROJ).c $(PROJ).h
+ install -m644 $(PROJ).h $(DESTDIR)$(PREFIX)/include/$(PROJ).h
+- install -m644 $(PROJ).pc $(DESTDIR)$(PREFIX)/lib/pkgconfig/$(PROJ).pc
++ install -m644 $(DIST)/$(PROJ).pc \
++ $(DESTDIR)$(PREFIX)/lib/pkgconfig/$(PROJ).pc
+
+ uninstall:
+ rm -rf -- \