aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-02-01 22:09:07 +0800
committer宋文武 <iyzsong@gmail.com>2015-02-03 22:13:00 +0800
commit93dc836f9dcdd2037711454ff5babb35e755bc27 (patch)
treef76619ab9fba2598638e6bda4bb1594a202fd5a2 /gnu/packages/patches
parente99f4211856b3f8e605d967fd6aeeb2bdb8dff26 (diff)
downloadguix-93dc836f9dcdd2037711454ff5babb35e755bc27.tar
guix-93dc836f9dcdd2037711454ff5babb35e755bc27.tar.gz
gnu: Add librep.
* gnu/packages/sawfish.scm: New file. * gnu/packages/patches/librep-rules.mk.patch: New file. * gnu-system.am: Add them.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/librep-rules.mk.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/patches/librep-rules.mk.patch b/gnu/packages/patches/librep-rules.mk.patch
new file mode 100644
index 0000000000..4ea2a3ae1b
--- /dev/null
+++ b/gnu/packages/patches/librep-rules.mk.patch
@@ -0,0 +1,30 @@
+rules.mk.in: Don't set prefix, datadir, libdir, datarootdir and repdir.
+rules.mk.in: Use pkg-config to get the absolute path for repcommonexedir.
+
+Merged into upstream: <https://github.com/SawfishWM/librep/commit/a1f2db721aa5055e90f6a76fde625946340ed8cf>.
+
+--- librep_0.92.4.orig/rules.mk.in 2015-01-31 23:21:59.614751496 +0800
++++ librep_0.92.4/rules.mk.in 2015-02-02 18:56:55.097171657 +0800
+@@ -1,18 +1,10 @@
+ # rules.mk
+
+-prefix=@prefix@
+-datadir=@datadir@
+-libdir=@libdir@
++repcommonexecdir?=$(shell pkg-config --variable=repcommonexecdir librep)
++rpath_repcommonexecdir:=$(repcommonexecdir)
+
+-# shut up configure
+-datarootdir=@datarootdir@
+-
+-repdir=@repdir@
+-repcommonexecdir=@repcommonexecdir@
+-rpath_repcommonexecdir=@repcommonexecdir@
+-
+-rep_LIBTOOL=$(repcommonexecdir)/libtool --tag CC
+-rep_INSTALL_ALIASES=$(repcommonexecdir)/install-aliases
++rep_LIBTOOL:=$(repcommonexecdir)/libtool --tag CC
++rep_INSTALL_ALIASES:=$(repcommonexecdir)/install-aliases
+
+ # use this like:
+ # foo.la : foo.lo bar.lo