aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-21 19:24:54 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-21 19:24:54 +0100
commit8cc91fa04131e1b37339bd08c48b117f1c32aa29 (patch)
tree3f69b804e09a78a1a1ab0aa16927be2e9282551c /gnu/packages/patches
parent94c43007200ba97879004db546dfc6bd8473da0d (diff)
downloadguix-8cc91fa04131e1b37339bd08c48b117f1c32aa29.tar
guix-8cc91fa04131e1b37339bd08c48b117f1c32aa29.tar.gz
gnu: Add weex.
* gnu/packages/ftp.scm (weex): New variable. * gnu/packages/patches/weex-vacopy.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/weex-vacopy.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/weex-vacopy.patch b/gnu/packages/patches/weex-vacopy.patch
new file mode 100644
index 0000000000..f593e86c08
--- /dev/null
+++ b/gnu/packages/patches/weex-vacopy.patch
@@ -0,0 +1,13 @@
+Taken from the Debian 2.8.0 package.
+
+--- weex-2.6.1.5/src/strlib.c 2003-08-18 11:52:38.000000000 +0200
++++ weex-2.8.0/src/strlib.c 2007-12-04 14:22:02.000000000 +0100
+@@ -42,6 +42,8 @@
+ # define G_VA_COPY(ap1, ap2) (*(ap1) = *(ap2))
+ # elif defined (G_VA_COPY_AS_ARRAY)
+ # define G_VA_COPY(ap1, ap2) g_memmove ((ap1), (ap2), sizeof (va_list))
++# elif defined (__x86_64__)
++# define G_VA_COPY(ap1, ap2) memmove ((ap1), (ap2), sizeof (va_list))
+ # else /* va_list is a pointer */
+ # define G_VA_COPY(ap1, ap2) ((ap1) = (ap2))
+ # endif /* va_list is a pointer */