aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-01-29 10:35:52 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-01-30 10:45:27 +0100
commit241e122193e6eee900cab1f3a1caec2f90603560 (patch)
tree728f0046a3d103ea7abd9739bc16b2326d68b190 /gnu/packages/patches
parente89fa047f76048ac907756a5f08ddc06c84c6c40 (diff)
downloadguix-241e122193e6eee900cab1f3a1caec2f90603560.tar
guix-241e122193e6eee900cab1f3a1caec2f90603560.tar.gz
gnu: bowtie: fix build errors
* gnu/packages/bioinformatics.scm (bowtie): Add 'supported-systems' field and add Makefile patch. * gnu/packages/patches/bowtie-fix-makefile.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bowtie-fix-makefile.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/bowtie-fix-makefile.patch b/gnu/packages/patches/bowtie-fix-makefile.patch
new file mode 100644
index 0000000000..5ac65731cb
--- /dev/null
+++ b/gnu/packages/patches/bowtie-fix-makefile.patch
@@ -0,0 +1,31 @@
+From 4a99b0023bdfbbe486b9649489a32ea184c18c9a Mon Sep 17 00:00:00 2001
+From: Valentin Antonescu <valentin@jhu.edu>
+Date: Tue, 2 Dec 2014 11:19:13 -0500
+Subject: [PATCH] Make sure the Mavericks test happens only under Darwin.
+
+---
+ Makefile | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d74f7c8..a4cdfa7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -54,12 +54,11 @@ endif
+ MACOS = 0
+ ifneq (,$(findstring Darwin,$(shell uname)))
+ MACOS = 1
+-endif
+-
+-ifneq (,$(findstring 13,$(shell uname -r)))
+- CPP = clang++
+- CC = clang
+- EXTRA_FLAGS += -stdlib=libstdc++
++ ifneq (,$(findstring 13,$(shell uname -r)))
++ CPP = clang++
++ CC = clang
++ EXTRA_FLAGS += -stdlib=libstdc++
++ endif
+ endif
+
+ POPCNT_CAPABILITY ?= 1