aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-12-17 19:32:05 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-12-18 11:20:56 +0530
commit01cb4d47570c38812492bbc331b7b818e1b69fbb (patch)
tree5b42cc9cb650c7d282df67660ed38ba6d1973649 /gnu/packages/patches
parent6a9659f5d88b082c3fa831a28ae953c4faed0efc (diff)
downloadguix-01cb4d47570c38812492bbc331b7b818e1b69fbb.tar
guix-01cb4d47570c38812492bbc331b7b818e1b69fbb.tar.gz
gnu: ansible: Work around issues with Guix wrapper scripts.
* gnu/packages/admin.scm (ansible)[source]: Remove ansible-wrap-program-hack.patch from patches. [arguments]: Add hide-wrapping and fix-symlinks phases. * gnu/packages/patches/ansible-wrap-program-hack.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ansible-wrap-program-hack.patch22
1 files changed, 0 insertions, 22 deletions
diff --git a/gnu/packages/patches/ansible-wrap-program-hack.patch b/gnu/packages/patches/ansible-wrap-program-hack.patch
deleted file mode 100644
index c2e1028392..0000000000
--- a/gnu/packages/patches/ansible-wrap-program-hack.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Ansible changes its behaviour depending on the name of the script that it is
-called as. Make it deal with guix' .real wrapper scripts.
-
-FIXME: Remove once wrapping ansible works properly.
-See http://lists.gnu.org/archive/html/bug-guix/2017-05/msg00015.html.
---- ansible-2.3.0.0/bin/ansible 2017-04-12 16:08:05.000000000 +0200
-+++ ansible-2.3.0.0-fixed/bin/ansible 2017-05-21 20:11:18.720872385 +0200
-@@ -75,7 +75,13 @@
- # sometimes add that
- target = target[:-1]
-
-- if len(target) > 1:
-+ if target[-1] == "real" and target[0].startswith('.'):
-+ target = target[:-1]
-+ target[0] = target[0][1:]
-+ if len(target) > 1 and target[1] != "real" :
-+ sub = target[1]
-+ myclass = "%sCLI" % sub.capitalize()
-+ elif len(target) > 2 and target[2] == "real" :
- sub = target[1]
- myclass = "%sCLI" % sub.capitalize()
- elif target[0] == 'ansible':