aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-27 11:48:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 11:20:28 -0400
commitd11d27e2e4a0e6d132127f5130533b0ce9d04481 (patch)
treef107bbd45293c7810fc1420bca6b66c416ef3e5d /gnu/packages/patches
parent34c8558af2d0a72a7f90dab9106addbf9b3e6c5f (diff)
downloadguix-d11d27e2e4a0e6d132127f5130533b0ce9d04481.tar
guix-d11d27e2e4a0e6d132127f5130533b0ce9d04481.tar.gz
gnu: guile-ac-d-bus: Run test suite.
* gnu/packages/patches/guile-ac-d-bus-fix-tests.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/guile-xyz.scm (guile-ac-d-bus) [source]: Apply patch. [phases]{check}: New phase. [native-inputs]: Add bash-minimal.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/guile-ac-d-bus-fix-tests.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-ac-d-bus-fix-tests.patch b/gnu/packages/patches/guile-ac-d-bus-fix-tests.patch
new file mode 100644
index 0000000000..19fd475c39
--- /dev/null
+++ b/gnu/packages/patches/guile-ac-d-bus-fix-tests.patch
@@ -0,0 +1,28 @@
+Submitted upstream: https://gitlab.com/weinholt/ac-d-bus/-/merge_requests/3
+
+diff --git a/tests/test-signature.sps b/tests/test-signature.sps
+index 278401b..cc5574f 100755
+--- a/tests/test-signature.sps
++++ b/tests/test-signature.sps
+@@ -43,6 +43,7 @@
+ (format-type-signature '(message BYTE BYTE BYTE BYTE UINT32 UINT32
+ (ARRAY (STRUCT BYTE VARIANT)))))
+
++(define fail-count (test-runner-fail-count (test-runner-get)))
+ (test-end)
+
+-(exit (if (zero? (test-runner-fail-count (test-runner-get))) 0 1))
++(exit (if (zero? fail-count) 0 1))
+diff --git a/tests/test-wire.sps b/tests/test-wire.sps
+index c3354bf..06ae73b 100755
+--- a/tests/test-wire.sps
++++ b/tests/test-wire.sps
+@@ -147,6 +147,7 @@
+ #x08 #x01 #x67 #x00 #x00 #x00 #x00 #x00 #x05 #x01 #x75 #x00 #x04 #x00 #x00 #x00
+ #x07 #x01 #x73 #x00 #x06 #x00 #x00 #x00 #x3A #x31 #x2E #x32 #x39 #x38 #x00 #x00)))
+
++(define fail-count (test-runner-fail-count (test-runner-get)))
+ (test-end)
+
+-(exit (if (zero? (test-runner-fail-count (test-runner-get))) 0 1))
++(exit (if (zero? fail-count) 0 1))