aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/vinagre-revert-1.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-21 02:40:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-21 02:40:37 +0200
commit2718a9cd096d0f5ae4b23cc0814a42aee5cf3c4d (patch)
tree334bed3ef9be203d77065a75380696c2537ede92 /gnu/packages/patches/vinagre-revert-1.patch
parent9c4ce3afac2ad42c832dc7a9f0932744b5fd8892 (diff)
parente904de7ec1789e243e830b19187b5ef550b2eefa (diff)
downloadguix-2718a9cd096d0f5ae4b23cc0814a42aee5cf3c4d.tar
guix-2718a9cd096d0f5ae4b23cc0814a42aee5cf3c4d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/vinagre-revert-1.patch')
-rw-r--r--gnu/packages/patches/vinagre-revert-1.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/patches/vinagre-revert-1.patch b/gnu/packages/patches/vinagre-revert-1.patch
new file mode 100644
index 0000000000..5a983770b7
--- /dev/null
+++ b/gnu/packages/patches/vinagre-revert-1.patch
@@ -0,0 +1,56 @@
+Patch taken from Debian: revert changes that prevent building against freerdp
+version 1.1 branch.
+
+From 8ebc0685b85e0d1f70eb00171f2e7712de3d44bd Mon Sep 17 00:00:00 2001
+From: Michael Biebl <biebl@debian.org>
+Date: Thu, 22 Sep 2016 01:15:55 +0200
+Subject: [PATCH 1/2] Revert "Improve FreeRDP authentication failure handling"
+
+This reverts commit d7b4f88943e8615d252d27e1efc58cb64a9e1821.
+---
+ plugins/rdp/vinagre-rdp-tab.c | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/plugins/rdp/vinagre-rdp-tab.c b/plugins/rdp/vinagre-rdp-tab.c
+index b731f9b..8572bc3 100644
+--- a/plugins/rdp/vinagre-rdp-tab.c
++++ b/plugins/rdp/vinagre-rdp-tab.c
+@@ -1195,8 +1195,8 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ VinagreTab *tab = VINAGRE_TAB (rdp_tab);
+ GtkWindow *window = GTK_WINDOW (vinagre_tab_get_window (tab));
+ gboolean success = TRUE;
++ gboolean authentication_error = FALSE;
+ gboolean cancelled = FALSE;
+- guint authentication_errors = 0;
+
+ priv->events = g_queue_new ();
+
+@@ -1205,12 +1205,14 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+
+ do
+ {
++ authentication_error = FALSE;
++
+ /* Run FreeRDP session */
+ success = freerdp_connect (priv->freerdp_session);
+ if (!success)
+ {
+- authentication_errors += freerdp_get_last_error (priv->freerdp_session->context) == 0x20009 ||
+- freerdp_get_last_error (priv->freerdp_session->context) == 0x2000c;
++ authentication_error = freerdp_get_last_error (priv->freerdp_session->context) == 0x20009 ||
++ freerdp_get_last_error (priv->freerdp_session->context) == 0x2000c;
+
+ cancelled = freerdp_get_last_error (priv->freerdp_session->context) == 0x2000b;
+
+@@ -1218,7 +1220,7 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ init_freerdp (rdp_tab);
+ }
+ }
+- while (!success && authentication_errors < 3);
++ while (!success && authentication_error);
+
+ if (!success)
+ {
+--
+2.9.3
+