aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/unzip-CVE-2015-7696.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-31 15:11:58 +0100
committerLudovic Courtès <ludo@gnu.org>2015-10-31 15:11:58 +0100
commitd9b9454c9865c148afc8498837e077581e43037d (patch)
tree528563f334c36e0c98981f5a41d23dbb948f6fff /gnu/packages/patches/unzip-CVE-2015-7696.patch
parent375c610844c7776470edb88eafb18c48c6c90187 (diff)
parent3c3e69728c10bcdffa0c597b2b80a482361aea14 (diff)
downloadguix-d9b9454c9865c148afc8498837e077581e43037d.tar
guix-d9b9454c9865c148afc8498837e077581e43037d.tar.gz
Merge branch 'dbus-update'
Diffstat (limited to 'gnu/packages/patches/unzip-CVE-2015-7696.patch')
-rw-r--r--gnu/packages/patches/unzip-CVE-2015-7696.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/unzip-CVE-2015-7696.patch b/gnu/packages/patches/unzip-CVE-2015-7696.patch
new file mode 100644
index 0000000000..d6a4072673
--- /dev/null
+++ b/gnu/packages/patches/unzip-CVE-2015-7696.patch
@@ -0,0 +1,35 @@
+Copied from Debian.
+
+From: Petr Stodulka <pstodulk@redhat.com>
+Date: Mon, 14 Sep 2015 18:23:17 +0200
+Subject: Upstream fix for heap overflow
+Bug-Debian: https://bugs.debian.org/802162
+Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1260944
+Origin: https://bugzilla.redhat.com/attachment.cgi?id=1073002
+Forwarded: yes
+
+---
+ crypt.c | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+--- a/crypt.c
++++ b/crypt.c
+@@ -465,7 +465,17 @@
+ GLOBAL(pInfo->encrypted) = FALSE;
+ defer_leftover_input(__G);
+ for (n = 0; n < RAND_HEAD_LEN; n++) {
+- b = NEXTBYTE;
++ /* 2012-11-23 SMS. (OUSPG report.)
++ * Quit early if compressed size < HEAD_LEN. The resulting
++ * error message ("unable to get password") could be improved,
++ * but it's better than trying to read nonexistent data, and
++ * then continuing with a negative G.csize. (See
++ * fileio.c:readbyte()).
++ */
++ if ((b = NEXTBYTE) == (ush)EOF)
++ {
++ return PK_ERR;
++ }
+ h[n] = (uch)b;
+ Trace((stdout, " (%02x)", h[n]));
+ }