aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/u-boot-pinebook-video-bridge.patch
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-11-20 16:32:16 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-22 21:59:05 +0100
commit74e35e8c94193a03cb1db61934340540ce0884a3 (patch)
tree4e94ca14c1977c2661d6dd857fbd3d78990c783a /gnu/packages/patches/u-boot-pinebook-video-bridge.patch
parenteff8e0b4d9d4b818150f64e151227e03fdcb5aab (diff)
downloadguix-74e35e8c94193a03cb1db61934340540ce0884a3.tar
guix-74e35e8c94193a03cb1db61934340540ce0884a3.tar.gz
gnu: Add u-boot-pinebook.
* gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch: New file. * gnu/packages/patches/u-boot-pinebook-syscon-node.patch: New file. * gnu/packages/patches/u-boot-pinebook-mmc-calibration.patch: New file. * gnu/packages/patches/u-boot-pinebook-video-bridge.patch: New file. * gnu/packages/patches/u-boot-pinebook-r_i2c-controller.patch: New file. * gnu/packages/patches/u-boot-pinebook-dts.patch: New file. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/bootloaders.scm (u-boot-pinebook): New exported variable. * gnu/bootloader/u-boot.scm (u-boot-pinebook-bootloader): New exported variable. * gnu/system/install.scm (pinebook-installation-os): New exported variable.
Diffstat (limited to 'gnu/packages/patches/u-boot-pinebook-video-bridge.patch')
-rw-r--r--gnu/packages/patches/u-boot-pinebook-video-bridge.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/patches/u-boot-pinebook-video-bridge.patch b/gnu/packages/patches/u-boot-pinebook-video-bridge.patch
new file mode 100644
index 0000000000..8c6ca8a992
--- /dev/null
+++ b/gnu/packages/patches/u-boot-pinebook-video-bridge.patch
@@ -0,0 +1,50 @@
+From 8336a43792a103c13d939b3925cb75322911f7fb Mon Sep 17 00:00:00 2001
+From: Vasily Khoruzhick <anarsoul@gmail.com>
+Date: Mon, 5 Nov 2018 20:24:29 -0800
+Subject: [PATCH 08/13] dm: video: bridge: don't fail to activate bridge if
+ reset or sleep GPIO is missing
+
+Both GPIOs are optional, so we shouldn't fail if any is missing.
+Without this fix reset is not deasserted if sleep GPIO is missing.
+
+Signed-off-by: Vasily Khoruzhick <anarsoul@gmail.com>
+Acked-by: Maxime Ripard <maxime.ripard@bootlin.com>
+Tested-by: Maxime Ripard <maxime.ripard@bootlin.com>
+Reviewed-by: Andre Przywara <andre.przywara@arm.com>
+Cc: Vagrant Cascadian <vagrant@debian.org>
+---
+ drivers/video/bridge/video-bridge-uclass.c | 16 +++++++++++-----
+ 1 file changed, 11 insertions(+), 5 deletions(-)
+
+diff --git a/drivers/video/bridge/video-bridge-uclass.c b/drivers/video/bridge/video-bridge-uclass.c
+index cd4959cc71..5fecb4cfd5 100644
+--- a/drivers/video/bridge/video-bridge-uclass.c
++++ b/drivers/video/bridge/video-bridge-uclass.c
+@@ -106,13 +106,19 @@ static int video_bridge_pre_probe(struct udevice *dev)
+ int video_bridge_set_active(struct udevice *dev, bool active)
+ {
+ struct video_bridge_priv *uc_priv = dev_get_uclass_priv(dev);
+- int ret;
++ int ret = 0;
+
+ debug("%s: %d\n", __func__, active);
+- ret = dm_gpio_set_value(&uc_priv->sleep, !active);
+- if (ret)
+- return ret;
+- if (active) {
++ if (uc_priv->sleep.dev) {
++ ret = dm_gpio_set_value(&uc_priv->sleep, !active);
++ if (ret)
++ return ret;
++ }
++
++ if (!active)
++ return 0;
++
++ if (uc_priv->reset.dev) {
+ ret = dm_gpio_set_value(&uc_priv->reset, true);
+ if (ret)
+ return ret;
+--
+2.11.0
+