aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-18 22:23:57 -0400
committerMark H Weaver <mhw@netris.org>2015-08-18 23:57:25 -0400
commit7cb6f648b2486b0e6060a333564432a0830637de (patch)
treebe5152f2b7171f58bf9cfa8036536dccee8d810f /gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch
parent2376963411a096aa0c8e77f27c4d1db1a9a7fa42 (diff)
downloadguix-7cb6f648b2486b0e6060a333564432a0830637de.tar
guix-7cb6f648b2486b0e6060a333564432a0830637de.tar.gz
gnu: qemu: Update to 2.3.1. Add fix for CVE-2015-5745.
* gnu/packages/patches/qemu-CVE-2015-5745.patch: New file. * gnu/packages/patches/qemu-CVE-2015-3456.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt3.patch, gnu/packages/patches/qemu-CVE-2015-5158.patch: Delete files. * gnu-system.am (dist_patch_DATA): Add new file and remove the deleted ones. * gnu/packages/qemu.scm (qemu): Update to 2.3.1. Add new patch and remove the deleted ones.
Diffstat (limited to 'gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch')
-rw-r--r--gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch76
1 files changed, 0 insertions, 76 deletions
diff --git a/gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch b/gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch
deleted file mode 100644
index 8a41848ddf..0000000000
--- a/gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From a9de14175548c04e0f8be7fae219246509ba46a9 Mon Sep 17 00:00:00 2001
-From: Kevin Wolf <kwolf@redhat.com>
-Date: Wed, 3 Jun 2015 14:13:31 +0200
-Subject: [PATCH 1/3] ide: Check array bounds before writing to io_buffer
- (CVE-2015-5154)
-
-If the end_transfer_func of a command is called because enough data has
-been read or written for the current PIO transfer, and it fails to
-correctly call the command completion functions, the DRQ bit in the
-status register and s->end_transfer_func may remain set. This allows the
-guest to access further bytes in s->io_buffer beyond s->data_end, and
-eventually overflowing the io_buffer.
-
-One case where this currently happens is emulation of the ATAPI command
-START STOP UNIT.
-
-This patch fixes the problem by adding explicit array bounds checks
-before accessing the buffer instead of relying on end_transfer_func to
-function correctly.
-
-Cc: qemu-stable@nongnu.org
-Signed-off-by: Kevin Wolf <kwolf@redhat.com>
----
- hw/ide/core.c | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/hw/ide/core.c b/hw/ide/core.c
-index 122e955..44fcc23 100644
---- a/hw/ide/core.c
-+++ b/hw/ide/core.c
-@@ -2021,6 +2021,10 @@ void ide_data_writew(void *opaque, uint32_t addr, uint32_t val)
- }
-
- p = s->data_ptr;
-+ if (p + 2 > s->data_end) {
-+ return;
-+ }
-+
- *(uint16_t *)p = le16_to_cpu(val);
- p += 2;
- s->data_ptr = p;
-@@ -2042,6 +2046,10 @@ uint32_t ide_data_readw(void *opaque, uint32_t addr)
- }
-
- p = s->data_ptr;
-+ if (p + 2 > s->data_end) {
-+ return 0;
-+ }
-+
- ret = cpu_to_le16(*(uint16_t *)p);
- p += 2;
- s->data_ptr = p;
-@@ -2063,6 +2071,10 @@ void ide_data_writel(void *opaque, uint32_t addr, uint32_t val)
- }
-
- p = s->data_ptr;
-+ if (p + 4 > s->data_end) {
-+ return;
-+ }
-+
- *(uint32_t *)p = le32_to_cpu(val);
- p += 4;
- s->data_ptr = p;
-@@ -2084,6 +2096,10 @@ uint32_t ide_data_readl(void *opaque, uint32_t addr)
- }
-
- p = s->data_ptr;
-+ if (p + 4 > s->data_end) {
-+ return 0;
-+ }
-+
- ret = cpu_to_le32(*(uint32_t *)p);
- p += 4;
- s->data_ptr = p;
---
-1.8.3.1