aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-16 01:01:54 -0400
committerMark H Weaver <mhw@netris.org>2015-06-16 01:01:54 -0400
commit7d02724b7bddb4d5e1cc93db99f737baa26840ca (patch)
treebae1377073af72dd17b7c786fd6991f234d3732b /gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch
parent4c10c6cbc61d703b18b92c651a92300cf51d1eab (diff)
parentfef3cfaaab972b1f514724f90050aeb38516519b (diff)
downloadguix-7d02724b7bddb4d5e1cc93db99f737baa26840ca.tar
guix-7d02724b7bddb4d5e1cc93db99f737baa26840ca.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch')
-rw-r--r--gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch b/gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch
new file mode 100644
index 0000000000..8d12d7ac5b
--- /dev/null
+++ b/gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch
@@ -0,0 +1,33 @@
+From c4ff1e68c621928abc680266cad0a451686c403b Mon Sep 17 00:00:00 2001
+From: Jan Beulich <jbeulich@suse.com>
+Date: Tue, 2 Jun 2015 15:07:01 +0000
+Subject: [PATCH] xen/pt: correctly handle PM status bit
+
+xen_pt_pmcsr_reg_write() needs an adjustment to deal with the RW1C
+nature of the not passed through bit 15 (PCI_PM_CTRL_PME_STATUS).
+
+This is a preparatory patch for XSA-131.
+
+Signed-off-by: Jan Beulich <jbeulich@suse.com>
+Reviewed-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
+---
+ hw/xen/xen_pt_config_init.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/hw/xen/xen_pt_config_init.c b/hw/xen/xen_pt_config_init.c
+index 516236a..027ac32 100644
+--- a/hw/xen/xen_pt_config_init.c
++++ b/hw/xen/xen_pt_config_init.c
+@@ -948,7 +948,8 @@ static int xen_pt_pmcsr_reg_write(XenPCIPassthroughState *s,
+
+ /* create value for writing to I/O device register */
+ throughable_mask = ~reg->emu_mask & valid_mask;
+- *val = XEN_PT_MERGE_VALUE(*val, dev_value, throughable_mask);
++ *val = XEN_PT_MERGE_VALUE(*val, dev_value & ~PCI_PM_CTRL_PME_STATUS,
++ throughable_mask);
+
+ return 0;
+ }
+--
+2.2.1
+